main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

Many websites don't work after the connection has been up for a while

vellori
2: Seeker

Hello,

I have an unlimited sim plan 5G and Huawei CPE PRO 2 router. The router is well placed and has a visual on the Vodafone antenna, the router web app reports perfect signal. This is confirmed by the speeds I get which is 500 download and 70-80 upload, pretty stable over day and night.

My problem is that after the connection has been up for a while, it starts to become unpredictable. The router still shows as connected, and I can perform speed tests using Speedtest by OOKLA on Vodafone UK server.

However when it happens some websites which I haven't visited recently, do not open and the browser shows connection timeout after a while. However, if I hit reload, it usually makes some progress and most of the times work, even though it might shows missing parts, or missing images.

I've been having this issues for months now and I have tried every possible suggestion by Vodafone support and Huawei support, including:

- reset the router multiple times, countless at this point

- change router position, current position shows best possible signal quality plus I have a visual on Vodafone cell tower (basing on information available on cell mapper website)

- use multiple different devices (I tried 2 laptops, the Smart TV, two iPhones, one tablet)

- use multiple different browsers: I tried Smart TV own browser, mobile Safari, mobile Chrome, Desktop Safari and Chrome

- replaced the sim card

- replaced the router (and made sure I installed the latest firmware)

 

I also tried some additional suggestions found online, such as:

- use google dns 8.8.8.8, 8.8.4.4

- use cloud fare dns 1.1.1.1, 1.0.0.1

 

If I use a VPN on my laptop or phone, the problem vanishes. However I don't feel like this is a solution because I have a large number of devices and smart-home appliance (18) and some of them do not support VPN. Additionally VPNs limit the max speed so those are not really a solution, but they prove it's not a physical connection issue.. more like a external routing problem perhaps?

The issue is just random: might happen in the morning, the afternoon or later when watching a movie.

 

To explain better: reloading a website isn't a big problem per se, but if that happen while using an app, streaming a movie or binge watching a serie... it gets frustrating very easily. Additionally while using apps or buying things online doesn't really offer a reload option, and sometimes you just need to do everything from the start again.

During this issue, even mail doesn't work well: I have an account on Apple iCloud and an account on outlook.com and both of them show the problem when the connection shows this particular behaviour.

 

Now I am very close to evaluate changing provider, because I am out of ideas (even if I have a 12 months contract for which I'll have to pay fees) - but having intermittent problems like this is very frustrating.

 

Basically I don't know what else to do: Vodafone had me speak to a number of support people and also one specialist, but none of them seemed to have other options (and to some I couldn't fully explain the problem because it can get a bit technical)

 

Any ideas? Somebody in Vodafone that would like to hang on this issue until it's solved?

 

Thanks!

View more options
4 REPLIES 4
Tash
Moderator

@vellori Thanks for posting this here and I appreciate you going into detail with the issues you're experiencing with your mobile router. 

I'm sorry to see that the troubleshooting our previous advisers have carried out haven't resolved this for you.

So I can help further, please can you let me know the postcode that you're using the router in? 

If you'd prefer not to share this on the thread, you can add this to your location in your profile where only our moderators such as myself can view this. 

Please also let me know if you're experiencing issues with the SIM when in another location/postcode - you can test this from the devices you mentioned above or the router itself if possible 👍

View more options
vellori
2: Seeker

Hello @Tash, 

thanks for replying.

 

My postcode is wc1x 8hn

I'm not sure I can perform those tests having similar conditions, as I mentioned I have quite a few devices and the issue happens after many hours of prolonged usage, which I wouldn't know how to do using just my tablet or my mobile phone someplace else. Additionally I can't leave my household with no connectivity, as everybody is working from home.

 

I believe the device should be fine, I picked this one specifically because:

- it is truly the top device available

- it's the same one I'd have gotten with Vodafone GigaCube (but I prefer to own my router) (same mode, see here at the bottom https://www.vodafone.co.uk/gigacube/ )

 

I did try other providers and it seemed to work well, with a much lower signal because I guess cell towers are different.

 

I forgot to mention I regularly check the Vodafone network checker and I subscribed to alert of issues in my area and, while there has been documented issues in the past months, nothing quite lasted from February to now

View more options
Mark
Moderator

I've taken a look at our coverage in your area @vellori and we've no issues at this time, the mast serving you (80212), is working as expected and has experienced no recent outages.

If you've a large number of devices connected to your router, each of these will use a little of your bandwidth and can affect your connection. You may want to disconnect any unnecessary devices when using it for work purposes. 

If you'd like us to complete an investigation into the issues you're experiencing, we'll need you to provide the information @Tash requested and we'll take a closer look 👀

View more options
chistery
15: Advanced member

I've been having a similar issue in E14 with Vodafone for a while now. Happening on an iPhone and Android so I know it's not my phone, but knowing how bad support is and how they will just blame me, I just can't be bothered to get through that awful bot, 1st line support and many questions and get nowhere. Good luck getting it fixed!

View more options