main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

Strange Alexa / One Number voicemail problem

Highlighted
4: Newbie

I set up my Amazon Echo / Vodafone One NUmber a few days back and almost immediately noticed a problem.

Here's the scenario:

  • My parents' phone automatically witholds their number on all outgoing calls.
  • I don't answer "unknown" calls on my mobile (I let them go to voicemail).
  • Therefore, for calling me, my parents have added the code 1470 in front of my number in their contacts.

Before setting up One Number, this all worked fine. However, now if they call me using the 1470 prefix and I don't pick up, the call just times out and does not go to my Vodafone voicemail. If they omit the prefix, then obviously I cannot tell who is calling, but the call does go to voicemail if I don't pick up. 

 

Seems like there is possibly some kind of incompatabilty between lines which withold their numbers and One Number?

 

Another possibility is that I have somehow accidentally "blocked" their number from my voicemail, so when they call with number withheld, they get through. Doesn't seem very likely, though, as I don't think this is even possible, and they can still call me anyway, assuming I pick up before the call times out. 

 

I feel like I need to test this some more from different phones, but its a bit difficult asking people to ring me up just so I can not pick up!  

View more options
3 REPLIES 3
Moderator
Moderator

Thanks for getting in touch @Digsy With this being quite a new service this is something we have not come across before. If you could do some more testing and let us know any results that would be great, one other thing to try so we can pinpoint whether the issue with diverting to voicemail is connected to the OneNumber service, is to see if you can ask your parents to do the same thing while calling a Vodafone number that is not connected on the OneNumber service and check if the number connects to the voicemail.

View more options
4: Newbie

Hi @TJ and thanks for the fast reply.

 

Pretty sure that both my folks have Vodafone mobiles so they could in theory call themselves but I don't think they use voicemail (their mobiles are hardly ever switched on) but I will ask.

 

I have also been trying to run some more tests by calling myself from my desk phone at work. This does divert to voicemail, but then again my work telephone system doesn't support the BT prefixes for witholding or revealing your number so I can't test that part.

 

What I do know is that if I call my own mobile number from my mobile, then my Amazion Echos ring and divert to voicemail whether or not I use a BT prefix to hide my number. The prefixes are definately working, because when I use "141" my Echo announces "Incoming call from a private number" whereas with "1470" or no prefix my Echo will announce the incoming call using my name as normal.

 

I don't have a traditional landline plugged in at home at the moment, but I will run a test using that as soon as I can.

View more options
4: Newbie

Looks like this issue might have gone away.

 

I ran tests with my own landline (prvided by Plusnet, so effectively BT). Went to voicemail whether or not I used the 141 or 1470 prefix, or no prefix.

 

Also got my folks to call their own Vodafone mobiles with and without the prefix. No problems - straight to voicemail.

 

So then I got them to try calling me again and hey presto - straight to voicemail, with and without using prefixes.

 

So God only knows whatever happened before, because whetever it was, it was 100% repeatable. Except now, oe week later, it isn't.

 

Will keep monitoring and report back if this issue crops up again.

 

View more options