main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

Underground wi-fi not working and worst customer service

Highlighted
3: Seeker

Been contacting you for more than a month about me not having underground wi-fi. It's been escalated a few times, still, nothing, keep getting the "you have a pre-pay bundle account error". While chat customer service says, they'll contact me later - and then forget to contact me back, or don't want to, I chat to someone else again, who is rude from the start and says to just try again.

 

Went to a store who says Vodafone is having problems agreeing on something with Virgin. I want some of my money back for the months I don't get wi-fi! I don't care what kind of agreement you have with Virgin, my agreement with you is that I have this wi-fi service.

 

And totally inexcusable, that your customer service, either didn't know, or were lying about it.

View more options
5 REPLIES 5
Moderator

Hi @User2302, I’m sorry to hear you’re having problems with Wi-Fi on the London Underground.

Please follow the steps on our London Underground Wi-Fi support page as this details a few different ways of connecting, which may get this sorted.

Let me know how you get on after trying this.

View more options
3: Seeker

Hi Jenny!

 

You're being very unhelpful just like Vodafone's customer service. I am getting an error message due to the account with Vodafone not being set up - as per my message. Please don't reply if you have no helpful solutions!

View more options
Moderator

It's a shame that you feel this way @User2302. With the error message you're seeing we'd need to ensure that your phone settings are correct to connect to the London Underground Wi-Fi. In some cases, the settings may not be set to the correct EAP method. Changing this should allow the Wi-Fi to recognise that you're a Vodafone customer through your SIM and allow you to connect without the need of a username or password.

If you're still having issues after trying the steps Jenny has provided, please get in touch with us via the private message I'll be sending shortly and a member of our team can help with this.

View more options
3: Seeker

It is a shame. But what's more of a shame is, that you think it's my settings that are causing this error message. My settings are configured correctly, went through them - I should have said that in my original post here. I was told countless of times by Vodafone customer service, they need to tweak my account due to my error message - as the error message is saying that I have a different account. Does that make sense? Wifi can be automatically recognised, but the first time, it does need a password.

 

Customer service tried correcting this on my account, have asked me to try again countless times, never worked.

 

Even sadder is that I went to the shop twice and got fobbed off twice for different reasons. 

 

It's a technical fault, and it's Vodafone's customer service that doesn't know how to fix problems - and I can say that with confidence, as I never get anything else, apart from "please wait" and "please try again". I have asked them to tell me what are they doing to my account so I can tell the next agent what's been tried - but they always politely change the subject - I have asked the same and same question countless of times.

 

I've never had these many problems with customer service being completely useless.

 

I have a technical error and need the tech department - how will escalating this to the social hub help, as per your PM? I realise, this forum isn't going to bring me a solution, but I am trying everything, and nothing has brought me a solution.

 

 

View more options
Moderator
Moderator

I'm sorry to hear about the problems you're having @User2302 and understand how frustrating this must be. What phone are you using at the moment? Have you tried entering your My Vodafone password when prompted?

From the error message you're getting, you'll need to try the following:

  • Are you trying to connect automatically? If not, make sure to connect to Vodafone Wi-Fi not Virgin Wi-Fi.
  • When under VodafoneWiFi coverage visit the “WiFi Settings” and tap on “VodafoneWiFi” in the access point list visible on the phone.
  1. Scroll to the top and view what the EAP method is currently selected.
  2. Edit the EAP method and change it to “AKA”. Then select “Connect”.
  3. If this does not connect to VodafoneWiFi, please wait 1 minute and repeat the above process and select “SIM” instead of “AKA” as the EAP method, then select “Connect”.

If this doesn't help, please get in touch using the private message that's been sent to you, so our team are able to access your account and investigate further; then escalate this to our Network team if needed. 

 

 

View more options