main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Pay monthly

Website security certificate coming from vodafone content control even though it's off.

2: Seeker

I am having the same problem, does vodafone have a solution yet?

View more options
2: Seeker

Vodafone is blocking https on imgur by giving an incorrect certificate. It is coming from contentcontrol.vodafone.co.uk, despite content control being off.

 

Browsers will not load the images and trying to look the the image url directly gives this error message on chrome:

 

This server could not prove that it is i.imgur.com; its security certificate is from contentcontrol.vodafone.co.uk. This may be caused by a misconfiguration or an attacker intercepting your connection.

 

This seems to be a widespread problem as many people complaining about it in this forum post which is incorrectly marked as solved:

https://forum.vodafone.co.uk/t5/Pay-monthly-products-services/Website-security-certificate-coming-fr...

 

I am not looking workarounds for individual computers, as I would like my Internet connection to work with all devices without having to mess around with settings etc.

 

Can someone from vodafone respond with why this is happening, or when we can expect it to be fixed?

 

 

View more options
17: Community Champion

Hi @vodafone_user2

 

 

This eforum is owned and monitored by Vodafone U.K. We have members of the Vodafone Tech Team who are available to respond and Help where they can. They have the Vodafone logo next to their name. All posts are read by them.
 
Hang in there and I'm sure they'll be in touch. 

IMG_1084.JPG

View more options
Moderator (Retired)

Hi @vodafone_user2

 

For this, please get in touch with the Broadband Team on 08080 034 515 to discuss this. 

 

Thanks, 

 

Cara

View more options
2: Seeker
You think I haven't tried that already? I've spent weeks of my life on the phone to Fixed Line and the issue has been "escalated" repeatedly. I keep being promised that it's being investigated and I'll hear back imminently but it never comes to anything. It's not something that needs resolved on an individual basis, it's affecting a large number of us, possibly even all Vodafone Broadband customers but many don't understand the issue or don't use any websites affected by it.

Someone needs to take ownership of this and make a decisive move toward resolving it.
View more options
3: Seeker

I've just moved to Vodafone braodband and norticed this issue straight away - especially using Imgur & Reddit.

 

Like everyone else I have all safety settings off - but this certificate issue stops me seeing pics.

 

I think I have a workaround thanks to the Vodaphone Router now being able to change DNS.

 

I logged into the router - 192.168.1.1, choose INTERNET / DNS & DDNS page, and set DNS to manual.

 

I then enter Google open DNS which are  8.8.8.8 and 8.8.4.4.

 

This seems to get around the issue.

View more options
2: Seeker
Sure, we could do that, but public DNS like Google's (especially when it's US based) tends to be extremely slow. We shouldn't have to hobble the 76Mbps fibre connection we're paying for to get basic functionality.
View more options
3: Seeker

I'm no fanboy - but it's hardly hobbled.

 

 

3: Seeker

+1 here.

 

I've had my Vodafone service for just over a week and I am being plagued by these prompts. Vodafone are performing a man-in-the-middle attack similar to what they describe here: http://vge-mktg.vodafone.com/SecurityAttackVideoJourney4

 

Rather than subverting a wifi router, they have a proxy server which is intercepting your encrypted data requests, making the connection to the encrypted endpoint itself and getting you to send your requests to the Vodafone proxy server. This means they can see any passwords, or banking information you send to the, now compromised, endpoint.

 

This is a huge breach of security which must be escalated to their highest level and resolved ASAP. An unwitting users who installs this certificate will have a seriously compromised system. It would allow Vodafone to listen in on all their secure communications... such as banking transactions and also allow them to collect passwords and login details for their users.

View more options
3: Seeker

pipefan413 wrote:
Sure, we could do that, but public DNS like Google's (especially when it's US based) tends to be extremely slow. We shouldn't have to hobble the 76Mbps fibre connection we're paying for to get basic functionality.

 

This isn't true.

 

Google's DNS servers are extremely quick. The server hardware and storage subsystems are state of the art. Their Internet connections are measured in tens of gigabits. 

 

In comparison your Vodafone router is extremely slow. Its low powered processor, small amount of RAM and slow storage system means that it takes a lot longer for it to search it's local database and return an answer to your lookup.

 

 

Switching to Google's DNS servers should give you a performance increase, as can be seen from the benchmarks I've attached...

 

192.168.1.2 is the DNS server running on my NAS which absolutely flattens all competition when is comes to returning cached lookups.

 

8.8.8.8 and 8.8.4.4 are the Google DNS servers which outperform the Vodafone router (192.168.1.254) in both cached and uncached lookups.

1: Seeker

There's definately something odd going on with Vodafones DNS. I run my own DNS server and when the router is set to use automatic DNS the responses from i;imgur.com take a couple of seconds.

 

When the router is set to use Googles public DNS (which were my DNS forwarders anyway) the response is instant.

 

I had a look in my DNS cache at the imgur records when the router was set to use Vodafones DNS and the records were marked as bad, but now they're OK.

 

I suspect some sort of transparent proxy possibly mixed with DNS based re-directs is going on. Any way, it's working now, thanks for the tip

View more options
4: Newbie
My only irritation is the way my local settings are ignored. I like to use the parental controls from opendns for the kids but Google's DNS for my computers. If you configure openDNS on the router it applies to everything no matter what you set locally :-(

View more options
4: Newbie

I'll just add my name to this thread - Vodafone you need to resolve this issue.

I am getting "too many redirect...." messages. However my content controls are turned off. We are an adult household and do not require Vodafone watching over us.

I will change the DNS server settings tonight as a temporary fix, however this does need resolving.

View more options
1: Seeker
Another irritated user - can we have a definitive answer on this please?
View more options
3: Seeker

I have been having this issue ever since I have been with Vodafone Fibre Broadband four months ago. It could just be co-incidental however. Or it could be connected. I don't know yet.

I am only having this problem with certain websites using the Safari and Chrome web browsers on my MacBook.

BBC's website and the iPlayer websites are just two in question.

I have an ongoing case with Apple Support about it as it seems to be only affecting my usual log in on my MacBook. 

I have set up a test user account on my MacBook and cannot replicate the same issues. All behaves as it should.

I am also having the same issue with my Outlook accounts using the Mail, Calendar and Notes apps.

It appears to be related to Globalsign the certifficate issuer. And the Apple Support Senior Adviser sent me this link explaining it:

 

https://downloads.globalsign.com/acton/fs/blocks/showLandingPage/a/2674/p/p-008f/t/page/fm/0

 

This is an ongoing issue. 

But it can be rectified in the meantime by setting up and using a different log-in on your computer.

I am not yet having this issue when using my other internet connected devices using my Vodafone Home Broadband connection.

I only came across this thread when i was investigating what was new with the new firmware update on my router. My connection went down yet again briefly last night and I had to re-connect via the dialog box that came up whilst browsing and once re-connected I noticed a new firmware version at the bottom of the page.

Needless to say it hasn't rectified this issue on my normal MacBook log in. And that's a point worth mentioning also.

I'm expecting a call back from Apple Support on Thursday 9th for an update.

Update:

To cut a long story short, I had to reset the 'key chain' completely on my usual log in on my MacBook. Apple said they'd seen it before and talked me through it. I forgot to ask them what caused it in the end because it took two one and a half hour phone calls to sort out. But I got the impression it can happen when you've had your device for a while. Not very helpful for this thread I'm sorry, but mine's working fine now.

 

View more options
Moderator

@Samtheboy15 @Jimroy Sorry to hear you're experiencing these issues. Our Broadband Live Chat team, will be able to assist you with this. 

View more options
2: Seeker

Well this is just astounding, It's been over a year since I last poseted here about having the same issues and there's still no fix ?

Why am I even still with Vodafone...

 

Infact what in the hell just happened ? I came back to this post to reply about having the issue again on a site I was trying to get on and half way through typing the post I clicked refresh on the site that was being blocked and suddenly its working, it even says its verified now.

 

Clearly there's something wrong here, you have people whos specific job it is to fix this stuff and yet your just asking for peoples router serial number and just replying with the generic copy paste responses that's used for everything.. ugh 1st line support.

View more options
2: Seeker

hi

 

im a new customer to vodafone broadband and im also having the same issues ive been on the phone to tech support and they didnt have a clue looks like ive signed up to the wrong broadband supplier had nothing but trouble ive had speed issues which an engineer was sent out to fix ive had an issue signing up and my installation date was knocked back 10 days and got billed twice for installation and router i should have stuck with plus net

 

anyway does anyone have any idea how to fix this issue?? i cant even send emails as i keep getting an error saying trying to reconnect to google

 

 

View more options
3: Seeker

Hi There,

 

I have just joined vodafone, and I have found whatever is going on with https very concerning.  I first noticed a problem with my noscript installation on firefox - where I had to disable the applications boundaries enforcer in order to access any https website.

 

Then I started to notice problems with imgur and the certificate being made out to vodafonecontentcontrol.co.uk (or something similar).  Obviously my content control is set to off.

 

This is hugely disappointing, and I would like an explanation from vodafone as to what is going on.  I am particularly concerned my security is compromised on this network as a result of this, and I don't understand why vodafone would recommend disabling the security features of https as a work around.

 

D

View more options
3: Seeker
I have just joined vodafone broadband, and I am having these issues. The google DNS fix seems to work for viewing imgur content, but I am concerned that I am having to switch off my noscript ABE settings in order to access any https website. The ABE is designed to prevent an external website accessing my local network, and it worries me that I am having to disable this in order to access the internet.
View more options