main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

Wifi calling on Samsung 9+

4: Newbie



I got a new S9+ on Friday - and have spent hrs talking to both Samsung + Vodafone to get Wifi calling set up (as i have poor reception)


I have restarted the handset, removed and reinserted the SIM maybe 50 times, done a factory reset, re-added APN settings mannually, read counltess forums etc etc


A helpful guy from Voda business support (onecom?) talked me through loads of ideas today - none of which resulted in the Wifi Calling option to appear


The last i got was to speak to Samsung...Samsung tell me its all there, and Vodafone need to enable it


Please can someone help, as im stuck in the middle  and cannot get this fixed / added to my brand new handset

Many Thanks

View more options
17: Community Champion



There is some advice in 》 Calling-features/wi-fi-calling 


And some general advice I've come across....


》 Calling Over WiFi Set up. Ask the agent to force the phone via sending an OTA configuration update that should provision your phone for Calling Over WiFi. 


"Register for Vodafone Wi-Fi Calling

Text the word CALLING to 97888

This is a free text which will add the service to your account

You should receive the following confirmation text:

Thanks. We’ll add Wi-Fi Calling to your account in the next 24 hours and will let you know when you’re all set up.

If you’d like to discuss this with us, or if you have any other issues, you can find more info here or contact us

Once you receive the confirmation text, switch on Wi-Fi Calling in your settings

Go to Settings, scroll down and choose the Application icon

Choose Phone and scroll down until you see Wi-Fi Calling – select the box beside this option

A pop-up will appear asking you to confirm if you want to enable Wi-Fi Calling – tap OK"

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui  / Pie.


Samsung Gear s3 Frontier Watch.

View more options
4: Newbie

i have done all that - read the same advice - asked the team to force a provision over the air (OTA) and sent several CALLING texts.  Voda tell me its handset consistently says otherwise.

View more options
17: Community Champion

A long shot but perhaps try....



" Not wanting to celebrate to soon but I think my problem with making wi-fi calls on my S7 has been solved. Yesterday I decided to do a check/update of my phones software via hard wire, rather than via wi-fi. Was uncertain that this would help but decided it was worth a try. Re-booted and 12 hours later re-booted again. I then did the following:


Opened "settings"


Selected "Connections"


Selected "apps"


 Clicked on the 3 dots (top right of screen)


Selected "Switch on System apps"


Scroll down to the first of 3 Phones and select


Select "More settings" at bottom of drop down box


Select and enable "Wi-F-calling"


Back to home page and re-boot.


I left my phone overnight and when I checked a small phone/wi-fi icon had appeared on my home screen. Tested calling and is appears to work as one would expect. "

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui  / Pie.


Samsung Gear s3 Frontier Watch.

View more options
4: Newbie

Thanks - my software is all upto date

i have checked the Phone settings literally about 50+ times and its not populated with Wifi calling

I am going to send the handset back and try again i think


View more options

Thanks for getting in touch @northy13 - we'd love to help get your Wi-Fi Calling back up and running. There's a customer who recently got back to us, advising that updating their IMEI on the account helped. You can find the thread here

So one of our team can take a closer look into this for you, please get in touch via Facebook, or contact us on Twitter. You can find more information on doing this here. Please provide a link to this thread, along with your username; so you won't have to explain yourself again. 

View more options