main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

sum only unable to download mail on data

4: Newbie

Two days ago i changed my contract to sim only. when on data it won’t let me download mail or login to webmail. 


however when on wifi i can connect to both. 


its giving me a certificate error. surely this would be the same on wifi. any help appreciated 

View more options
17: Community Champion

Hi @Adie_efc


Changing contract account type shouldn't really affect what you can access. 

My suggestion is to double check the settings and if necessary delete the email account from your phone and reset it back up. 

Perhaps try another email app too. 

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui  / Pie.


Samsung Gear s3 Frontier Watch.

View more options
17: Community Champion

Hi @Adie_efc


Please see this previous thread There is a reply from @hrym answering a post with the same problem.


As @hrym mentions wait for the Team to get to the thread, they will be able to investigate this for you.


@Alex it might be worth mentioning there has been no reply to the linked thread and the OP still needs help as of the 22nd November.

View more options
12: Established

Does the mail client have the option 'accept all certificates' or words to that effect?

My brain training puzzle site - It's good go look

View more options
4: Newbie

i’m using the standard iOS mail app and i’ve not seen any options for certificates 

View more options

@Adie_efc - Please take a look at this link from Apple. If it’s still the same after, please attach the error message you’re getting.

View more options
4: Newbie

Hi Gemma


I finally got this solved by having the SecureNet software removed from my account. This solved the problem immediately.

Given I had asked when I transferred to the new contract not to have it I was increasingly frustrated. A nice gentleman from the Egypt office removed it and within 2 mins it was working as expected.

View more options