main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Unlocking

Huwawei HG556a with Huawei E173 datacard

2: Seeker

I'm using Huawei HG556a with a Huawei E173 USB HSPA Modem. I have been using it fine but recenly after I reset the router, it desn't seem to connect to the internet using USB Modem automatically. Everytime I shut down the PC, it disconnects and I need to reconnect it either by turning on the computer or using my phone after going in to routers page. This never happend before. It used connect to the internet automatically and stay that way until I tun off the router. Any ideas about what's going on?

 

View more options
5 REPLIES
Moderator (Retired)

Hi aroshlakshan,

 

Thanks for posting. 

 

The first thing I'd check is software updates for your modem. You can get the latest version here.

 

If this doesn't help can you try uninstalling the modem software from your computer and installing it fresh.

 

Let me know the outcome.

Cheers, Ben

View more options
2: Seeker

Thank you for the response. I plug in the modem in to my router. I'm not using it by plugging in to the computer.

View more options
Moderator (Retired)

Hi aroslakshan, 

 

Can you let us know if you have the latest software installed? If not then please give this a go and let us know how you get on. 

 

Thanks, 

 

Kay

View more options
2: Seeker

Router and the data card is updated to the latest firmware. 

View more options
Moderator (Retired)

Hi aroshlakshan,

 

To be honest we’re very restricted as to what support we can give, as it’s not a Vodafone UK product.

 

Where did you get the modem from?

 

When you log into the admin panel, is there a default connection option?

 

James

View more options