main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Vodafone Sure Signal

New sim card on admin account

2: Seeker

I've just recently upgraded to a new phone and had a new sim card installed, but same number! This won't work on my Sure Signal and as I'm the admin, I thought I would just change the admin number, delete my number, re add my number again and make me admin again! Trouble is, each time I've tried this on two different numbers registered on my Sure Signal and using two different emal addresses, the emails got kicked back! I had to end up deleting the pending admin number and then re add it again, to get me out of that section! I hope that makes sense, but what can I do to resolve this?

View more options
4 REPLIES 4
17: Community Champion

Hey @Captainred

 

Have you tried speaking with Vodafones Customer services on 191 or Live Chat can access your account and help. 

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui  / Pie.

 

Samsung Gear s3 Frontier Watch.

View more options
17: Community Champion

Hi @Captainred

 

If you have already tried temporarily changing ownership to one of the other numbers as detailed on the link below, you will need to deregister the Sure Signal, leave it for 24 hours to settle down reregister and add the admin and other numbers.

 

My Sure Signal is working but not with my phone. What can I do?

View more options
2: Seeker

I've tried changing the ownership, but when the pending admin bit comes up, for some unknown reason, the emails sent to the other account user get sent back with errors! Chat wasn't on last night, so couldn't go on it, but I could try again today

View more options
2: Seeker

Finally been sorted, but it was complicated and the person on Live Chat couldn't fix it last night (although I thought they had, but after the 2-4 hours I was told to wait, still no service) and this morning, the rep contacted their specialist team and they've seemed to have sorted it once and for all. Thanks for all your help, much appreciated

View more options