main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Vodafone Sure Signal

Replacement Vodafone Suresignal 3 - no power light

4: Newbie

Dear Vodafone custoimer support,

Just over a year ago, our Sure Signal 3 blew up and was replaced by Vodafone - well we replaced it, were informed of the widespread issues and were refunded. We were reassured that the manufacturing problem had been fixed. 
Something similar is happening again - it started about 3 weeks ago, maybe 4  While it has not blown that I can tell (no smell), there is no power light most of the time, and only the network traffic indicator is showing any signs of life. Occasionally the red light comes on, but again nothing happens, and resetting the box simply leaves no lights active. When the red light comes on (takes 20 to 90 minutes) the box gets very hot (like the old one did before it went pop). It's in it's own socket and does not have another plug in the front socket, never has done.
I'd be most grateful if Vodafone can replace this with a safe functioning Sure Signal box. How do I go about arranging this please?
Thanks in advance.
Marc

 

 

View more options
5 REPLIES 5
17: Community Champion

There was indeed a known issue with some of the v3 Sure Signal devices. 

The devices do come with a 24 month manufacturing warranty. 

Either call 191 or Live Chat or pop into a Vodafone Highstreet Store and they'll help you with this @SparkyT

To add I'd suggest to remove the Sure Signal from the mains socket if you haven't already done so. 

Current Phone > Samsung Note 9 _512Gb > Model: SM-N960 Hybrid-Duos.

Samsung One Ui  / Pie.

 

Samsung Gear s3 Frontier Watch.

View more options
4: Newbie

Ta, box and receipt located, so it's off to their shop I go. 

View more options
Moderator
Moderator

Hey @SparkyT, did you pop into store with your Sure Signal? What did they advise? If you're still having any problems, don't hesitate to get back in touch and we'll be happy to help in any way we can.

View more options
4: Newbie

Thank you.
Yes, all good at the store. Successfully registered the replacement BUT unable to add users - keep getting this error message:

"Sorry, there seems to be a problem.

We're working hard to fix the issue, so please try again later.: 500, 2004 - [Error ref 1b1]"

EDIT - @TJ, fired up in a different browser after clearing cache - all good now. Appreciate you checking back in with me to make sure all was well.


View more options
Moderator
Moderator

Awesome stuff 👍 We're glad to hear you're up and running again @SparkyT!

If you have any other questions in the future don't hesitate to pop back, we'll be happy to help in any way we can.

View more options