main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Vodafone Sure Signal

Sure Signal device has been suspended without notice or permission.

Highlighted
2: Seeker

I received a text to tell my my SureSignal device hadn't been used for some time would "automatically be suspended soon".  In fact, when I immediately checked, there was no reference to SureSignal on my account and the device had already been switched off - no lights, completely dead.  I called Vodafone and was told there is nothing to be done but buy a new device.  I'm furious:

a)  the warning text arrived after the apparent suspension

b) Vodafone's agent (and her supervisor) could do nothing to assist except suggest I visit a Vodafone store and buy a new device

c) Vodafone can switch off a device remotely but not, apparently, restore it

d) this isn't a subscription device - it's paid for and Vodafone has rendered it useless without notice or permission

e) Whilst I can use wifi calling, I don't always have my 'phone wifi on and the signal provided by Vodafone at my home is unusable without a booster.

Has anyone else had this experience and if so, what to do??

 

 

 

 

View more options
2 REPLIES 2
Moderator

Thank for reaching out to us about this @libbyearle. You're Sure Signal does get suspended if it's not been used for a long time, I'm sorry that this has incorrectly happened to yours whilst it's still being used. I'm sorry our Customer Services team were unable to get this lifted for you. I'll be happy to look into why this was and if possible restore your service. As I'll need access to your account to do this, please get in touch by following the instructions in this private message and I'll be in touch.

View more options
2: Seeker

Thanks!  Responded in PM.  For others' interest, what does Vodafone deem to be "a long time"?   I guess I may have been using wifi calling and not realised the SureStart box felt ignored?

View more options