main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Vodafone Sure Signal

Sure Signal v1 Not Connecting

Highlighted
2: Seeker

Hi,

Having problems with the Sure Signal v1 for over a week now. It constantly cycles through the same sequence of lights as follows:

- Solid 1
- Cycle through 1, 2, 3, and 4
- Solid 1
- Solid 1 and flashing 2
- Solid 1 and 2
- Solid 1 and 2 with 4 flashing
- Solid 1 and 2
- All off

And repeat ad infinitum.

 

I've been through the instructions in Resetting your Sure Signal  and I see the same behaviour. I've de-registered and re-registered the Sure Signal and received texts to indicate this has completed, but still not joy.

 

To try and track down what's going on I've run tcpdump on my broadband router and see the following:

- Sure Signal requests and receives time via NTP from 212.183.131.133
- Sure Signal sends IKE initialisation and authentication to 212.183.133.179 (initial-ipsecrouter.vap.vodafone.co.uk)
- Sure Signal and 212.183.133.179 (initial-ipsecrouter.vap.vodafone.co.uk) commence IPSec ESP session over UDP port 4500
- Sure Signal sends UDP packets to 212.183.133.179 on port 33434, 33435 and 33436
- Sure Signal sends IKE initialisation and authentication to 88.82.13.171
- Sure Signal and 88.82.13.171 commence IPSec ESP session over UDP port 4500
- Sure Signal sends UDP packets to 88.82.13.171 on port 33434, 33435 and 33436
- Sure Signal sends IKE initialisation and authentication to 212.183.133.178
- Sure Signal and 212.183.133.178 commence IPSec ESP session over UDP port 4500
- Sure Signal sends UDP packets with TTL 4 to 212.183.133.178 on port 33434.

- Sure Signal reboots and the above repeats

 

The UDP packets that are sent to ports 33434 etc., are kind of odd in that they all have a very low IP TTL of 4 and so never make it to the destination.

 

Not quite sure where to go after this. Any ideas greatly appreciated.

 

Regards

View more options
10 REPLIES
17: Community Champion

Hi @smf22

 

It may also be worth trying a different power supply with the SureSignal (Version 1 & 2 ), even if it still looks ok regarding lights etc as there have been some reports of replacement power supplies solving the issues as they can degrade. They are available on eBay for around £10.

 

From member cineriv "But firstly, have a look around for a suitable unit with a 12 Volt output @ around 1.5Amp capacity that you could 'borrow' to prove the fault. Suitable units can be found on external hard drives, monitors, printers, routers etc.etc."

Current Phone > Samsung Note9 _512Gb > Model: SM-N960 Duos.

Samsung Gear s3 Frontier Watch.

View more options
Moderator

If you're still experiencing problems using your Sure Signal @smf22, please try the steps in our troubleshooting guide.

 

View more options
2: Seeker

Thanks Mark. Looking through the only one relevent is Light one on, light two flashing and...

 

- Wait 24 hours: Been over a week now.

- Check that your Sure Signal has registered successfully: Done, and as I mentioned I've received email notification to that effect.
- Manually configure your router to allow port-forwarding: Not needed, and again as I mentioned, I can see traffic with the tcpdump (network packet capture) to and from the IP addresses mentioned in the troubleshooting guide.

 

I've also been through the Resetting your Sure Signal and this has not helped either.

 

Regards

View more options
Moderator

Thanks for the update @smf22. So we can investigate your Sure Signal issue further, please complete our troubleshooting template and we be in touch soon.

View more options
2: Seeker

Hi @Mark,

Requested details as follows:

The issue you’re experiencing:

Sure Signal v1 not connecting.

What light sequence you're seeing:
- Solid 1
- Cycle through 1, 2, 3, and 4
- Solid 1
- Solid 1 and flashing 2
- Solid 1 and 2
- Solid 1 and 2 with 4 flashing
- Solid 1 and 2
- All off
- And repeat

Your speed test results:

 

DOWNLOAD_MEGABITS UPLOAD_MEGABITS LATENCY_MS SERVER_NAME
54.87             15.18           9          Eastbourne

Your external IP address:
86.X.Y.37 (obfuscated as public forum)

 

Your Sure Signal serial number:
21227848567

Traceroute:

 

smf22@host:~$ sudo traceroute 212.183.133.177
traceroute to 212.183.133.177 (212.183.133.177), 30 hops max, 60 byte packets
 1  erx1 (192.168.1.1)  0.399 ms  0.441 ms  0.339 ms
 2  * * *
 3  * * *
 4  31.55.186.188 (31.55.186.188)  8.376 ms  8.348 ms  8.338 ms
 5  core4-hu0-17-0-9.faraday.ukcore.bt.net (213.121.192.64)  10.334 ms core3-hu0-14-0-5.faraday.ukcore.bt.net (195.99.127.38)  7.883 ms core4-hu0-8-0-3.faraday.ukcore.bt.net (213.121.192.68)  8.554 ms
 6  peer6-hu0-12-0-0.telehouse.ukcore.bt.net (213.121.193.189)  8.732 ms peer6-hu0-2-0-0.telehouse.ukcore.bt.net (213.121.193.197)  10.119 ms 213.121.193.199 (213.121.193.199)  9.987 ms
 7  t2c3-et-3-1-0-0.uk-lon1.eu.bt.net (166.49.211.236)  9.959 ms t2c3-et-7-1-0-0.uk-lon1.eu.bt.net (166.49.211.228)  9.338 ms t2c3-et-7-3-0-0.uk-lon1.eu.bt.net (166.49.211.230)  8.816 ms
 8  166-49-211-254.eu.bt.net (166.49.211.254)  9.645 ms  8.885 ms  8.706 ms
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

Note that whilst traceroute is being dropped traffic captured with tcpdump can be seen between the Sure Signal and the mentioned host 212.183.133.179:

root@erx1:/home/smf22# tcpdump -n -i switch0.101 host 212.183.133.179
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on switch0.101, link-type EN10MB (Ethernet), capture size 262144 bytes
08:48:15.235674 IP 192.168.1.64.4500 > 212.183.133.179.4500: NONESP-encap: isakmp: child_sa  inf2[I]
08:48:15.248680 IP 212.183.133.179.4500 > 192.168.1.64.4500: NONESP-encap: isakmp: child_sa  inf2[R]
08:48:16.162216 IP 212.183.133.179.4500 > 192.168.1.64.4500: UDP-encap: ESP(spi=0xc698ad7b,seq=0x74b), length 132
08:48:16.165056 IP 192.168.1.64.4500 > 212.183.133.179.4500: UDP-encap: ESP(spi=0x3444343b,seq=0x74f), length 132
08:48:17.099609 IP 192.168.1.64.4500 > 212.183.133.179.4500: UDP-encap: ESP(spi=0x3444343b,seq=0x750), length 132
08:48:17.113140 IP 212.183.133.179.4500 > 192.168.1.64.4500: UDP-encap: ESP(spi=0xc698ad7b,seq=0x74c), length 132
08:48:20.908480 IP 212.183.133.179.4500 > 192.168.1.64.4500: UDP-encap: ESP(spi=0xc698ad7b,seq=0x74d), length 132
08:48:20.910541 IP 192.168.1.64.4500 > 212.183.133.179.4500: UDP-encap: ESP(spi=0x3444343b,seq=0x751), length 132
08:48:21.689217 IP 192.168.1.64.4500 > 212.183.133.179.4500: UDP-encap: ESP(spi=0x3444343b,seq=0x752), length 100
08:48:21.701919 IP 212.183.133.179.4500 > 192.168.1.64.4500: UDP-encap: ESP(spi=0xc698ad7b,seq=0x74e), length 100
08:48:25.919623 IP 192.168.1.64.4500 > 212.183.133.179.4500: UDP-encap: ESP(spi=0x3444343b,seq=0x753), length 132
08:48:25.932945 IP 212.183.133.179.4500 > 192.168.1.64.4500: UDP-encap: ESP(spi=0xc698ad7b,seq=0x74f), length 132
08:48:26.741794 IP 212.183.133.179.4500 > 192.168.1.64.4500: UDP-encap: ESP(spi=0xc698ad7b,seq=0x750), length 132
[...]

 

View more options
Moderator

Thank you for providing this information @smf22. The light sequence you've provided indicates your Sure Signal is struggling to maintain a connection to our network. I've requested this to be resynchronised, this can take 6 hours to complete. After this time restart you phone in range and your service will be restored.

View more options
2: Seeker

I'll keep an eye and test this later. Thanks @Mark for your assistance with this.

Regards

View more options
2: Seeker

Hi @mark,

It's been 24-hours now and still no joy with this. Turned phones off and on, Sure Signal off and on and also reset the Sure Signal.

The light sequence is repeating as before: 1 solid -> 1, 2, 3, 4 cycle -> 1 solid -> 1 solid, 2 flash -> 1 solid, 2 solid, 4 flash -> 1 solid, 2 solid -> 1 solid -> 1, 2, 3, 4 cycle.

Packet capture still shows the same: NTP to 212.183.131.133 and 212.183.133.181, IKE to 212.183.131.131, 212.183.133.178 or 212.183.133.179 and UDP encapsulated ESP to 212.183.131.131, 212.183.133.178 or 212.183.133.179.

Getting pretty desperate now as there's no Vodafone signal in my house without the Sure Signal.

Regards

View more options
Moderator

@smf22 Thanks for updating us and I'm sorry to hear that the resync hasn't restored your service for you.

I've raised this with our technical team and they can see that there are multiple failures whe connecting to our servers. This would determine that the device is faulty and would need to be replaced.

If you'd prefer not to purchase a new Sure Signal to help improve your coverage at home, you do have the option to add Wi-Fi Calling to your price plan free of charge. This would allow you to make and receive calls through your Wi-Fi. 

View more options
2: Seeker

Thanks @natasha for looking into this and your note on WiFi calling.

I'm interested to understand in what way "the device is faulty". Clearly the hardware is functional as the lights cycle through a seemingly known pattern. As for the software, well that would seem to be functional to. The device is able to boot the operating system and then use the  Dynamic Host Configuration Protocol to ask anyone on my LAN for an IP address. Once provided with an IP address it knows it needs to understand the time and so requests that via the Network Time Protocol (NTP). It also understands that it should use security when passing data across the Internet, and so using the Internet Key Exchange (IKEv2) Protocol and UDP Encapsulation of IPsec ESP Packets establishes a secure connection. And not only does it establish a secure connection, but it knows that's a Vodafone Sure Signal and so connects to Vodafone systems with the IP addresses 212.183.131.133 and 212.183.133.181 for NTP, and 212.183.131.131, 212.183.131.139, 212.183.133.177, 212.183.133.178, 212.183.133.179 and 88.82.13.179 for IPSec.

So it knows and is able to achieve all this whilst being faulty. That's truly amazing.

Perhaps it's not actually faulty at all, but Vodafone, despite their statements of supporting a 'low carbon economy' and empowering 'customers to make more sustainable choices about the products' would rather I simply throw the thing away and buy another one. Solves the problem, and puts more money into the Vodafone coffers at the same time.

But of course... I forgot. I don't need a functioning Sure Signal. I can add WiFi calling to my plan free of charge. But alas no as the the phones I have don't support WiFi calling. No problem I'll throw those into the same bin as the Sure Signal and buy models that do support WiFi calling.

Seems to me the best course of action is to move provider to one that can give me the service I pay for.

View more options