Showing results for 
Search instead for 
Did you mean: 






Apple Watch Cellular not working

3: Seeker
3: Seeker

I recently aded an Apple Watch Series 3 to my Vodafone plan. Last week it worked fine but now not at all.

I've tried all the tech support suggestions (after 2hrs on the phone).... Unpair, Delete the app, re-boot the watch, pair again, set up as a new watch..... and still Vodafone mobile data is not working.

I can see in my account details that a secondary number for my watch exists alongside the primary number for my phone. Despite that, when I try to set up Mobile Data on the watch app it tells me that I can't use this plan with Vodafone One Number.... I don't even know what that is.

Are there any new fixes for this?


4: Newbie

See above link that has 665 comments on the same issue. Its a problem with vodafone that they're yet to admit too. which is the frustrating thing about it. I'm awaiting either a better offer of compensation or a deadlock letter so i can take this to the ombudsman. luckily mine has started working. but only after spending probably around 12-15 hours in total talking to vodafone through various means. all of which not actually knowing what the issue is or what to do about it so instead try fobbing me off with lies.

I'm getting a similar experience - when I go through the setup mobile data screens within the watch app, I'm getting a message stating my plan isn't eligible for Vodafone OneNumber.  Speaking to care I'm hearing that getting this particular message seems to be appearing when it shouldn't, and my plan IS eligible.  I've got an addtional line setup on my account (I can see it when I log into the online portal), and I've provided my EID to the new connections team, but when I go into my Apple Watch App, I'm still seeing the option to 'Setup Mobile Data', so the eSIM profile needed on my Watch isn't associated correctly by the looks of things.


Did it magically start working at some point, or did you have to go through the 'Setup Mobile Data' steps to get things up and running?  I've been promised a call back from the technical team within the next 48 hours, but it's a little annoying that my new plan started 2 days ago, and I can't actually use it, even if it is free for the next 6 months.

So, I’m still waiting for my watch and to be fair, in no rush as i would like all the issues sorted before I receive it. Don't fancy the hassle that people are having. To ensure things go smoothly,  thought I’d check that everything is set up correctly their end after I had pre-ordered on the £22 for 6 month then £27 deal and was told then, that all is good and i just had to link it in upon receipt.

I've been told that my current plan is not compatible with the watch at all and have to pay more money per month for a different contract. I've read on here that some came across this issue but is it actually correct?

I've obviously told them I wasn't told about an issue with compatibility or certainly a further increase on top of the watch cost/contract when I ordered it so won't be paying any more. Was put on hold for 10 minutes and then he said he'd call back as he'd get it sorted for me. That was some time ago........ Has anyone else who got this working had this additional problem and how was it resolved?

My current contract runs out 1st Feb 2019 so if it all goes wrong, I think i'll hold out and go to EE in Feb.

Thanks in advance for any guidance.


****UPDATE. Have been called back and my data plan has been increased from 1gb to 16gb pm for the same cost and the account should work with the watch. I also had a text the other day that I will be getting a free wireless charger on delivery of watch due to the delay etc.!!  So, I guess anyone waiting for the watch should at least call first to try to prepare for when it arrives to avoid any more issues if possible? Let's hope the watch actually links up when I finally get it.





Moderator (Retired)
Moderator (Retired)

Hi @vegasvic2005 we're more than happy to look into your query further. So we're able to access your account, please send us your details by following the steps on the private message I've sent you. 


@jamescarlin The same applies here, we're more than happy to see what's going on for you, please check the private message I've sent you for details on how to get in touch. 

If I were you I’d stop getting involved because you can’t help anything out at all. So stop wasting our time. 

I’ve had same issues since day 1 (iWatch 4 from Apple directly) ordered One Sim tariff.

Spent hours and hours days after day trying to resolve.

Told to go into Store. Who then say I shouldn’t have been sent in. The manager had same issue with her own iWatch which is now working.

I’ve provided my EID several times. Latest, today, told they have processed my EID, but now they need to wait for a network update!!!!

What is going on. Please Mod, can anyone help.

I’m worried that my 30 days is running out which means I’ll be stuck on a tariff that I won’t be able to cancel if it doesn’t work!

Had a text week ago.....

”Good Afternoon,

Just to let you know I have submitted your EID 32 digit with a super user. I do apologise we do have a delay on our side with order's this may take longer than 24 hours, I do appreciate your patience.

Many thanks,
Vodafone Complaints”

...... Still not working.

Moderator (Retired)
Moderator (Retired)

@MrJG It's really disappointing to hear you're having problems with your Apple Watch and I understand how frustrating this must be. 

We'll be happy to take a closer look into this for you. I've sent you a private message with details on how to get in touch with our team 😊


Did anybody get a response from Vodafone? 

Im having issues connecting my watch to my mobile data and keep getting error code ‘2005’ call 191. Vodafone are saying that they will escalate but I have to wait a week for someone to get back to me. 


Still waiting :Sad_face: