main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

iOS

Mobile shows 4G signal but no internet access

3: Seeker

Hi,

 

My iphone 6s suddenly stopped accessing internet using my data package.  The phone shows full signal with 4G and I've checked and there's not a network issue.  

 

I've phoned 191 and followed their advice - rebooted my phone, reset network settings, reinstalled the APN profile - but still doesn't work.  I went into a vodafone store but all they could suggest was a new SIM card.  That hasn't helped.

 

Weirdly it happened 30mins after I had to phone 191 to make sure I didn't lose my entertainment pack.  Not sure if the call assistant has done something to my account settings by mistake but they look ok when I check the vodafone app.

 

Has anyone got any ideas?  I'm pulling my hair out!!

 

Thanks :-)

View more options
26 REPLIES
17: Community Champion

Hi,

 

Can you try your Sim Card in another phone as a process of elimination to rule out the phone or sim card that may be at fault. Try another Sim in your phone. If necessary any Vodafone Shop can replace the Sim Card via a Sim Swap. 

 

An Apple Store can run a diagnostic on the iPhone. 

 

Have you tried turning 4G off in the phones settings to see if that helps. 

 

Also so check in your online myvodafone to see if any relevant account bars have been turned on. 

 

Look at http://support.vodafone.co.uk/Setting-up-and-using-your-device/Your-phone-s-settings/38913427/How-do...

IMG_1084.JPG

3: Seeker
Hi,

Great thinking. I swapped SIM card with a friend's phone and my iPhone worked fine with full 4G connectivity. When I put my SIM in their phone, no data. So it looks like it's a problem with Vodafone not my hardware.

I've had a new SIM so it's not a SIM issue.

Had phoned Vodafone yesterday but they said there wasn't a bar on my account. Guess I'm going to have to phone back again!

Is there any way to speak to their tech team directly?

Cheers!



View more options
Moderator (Retired)

Hi @docrox22

 

This definitely looks like you'll need to speak to us on 191 again. Have you been back through? Any update? 

 

Cara

View more options
3: Seeker
Hi Cara,

I called 191 and it's been escalated to the price plan team. Seems plausible as it happened 6months exactly from when I took out my current contract. Frustratingly they said that it would take 3-5 working days before they could come back to me. Is there any way to escalate further? It's a real issue not having internet access on the move as I rely on it for work emails etc.

Thanks for your response!

View more options
Moderator (Retired)

Hi @docrox22

 

Thanks for the update on this, you'll need to wait the 3-5 working days before anything more can be done, fingers crossed no further action will need to be taken after this though. Please come back and let us know how you get on when you have another update, I completely understand your frustration and I apologise. 

 

Cara

View more options
2: Seeker
Hi just wondering if this got resolved and if so, what was the cause / how was it sorted! Having exactly the same issue and getting a bit frustrated having now done 2 SIM swaps, been into 2 stores and onto 191 customer services for almost 2 hours in total 😡. Any advice much appreciated!
View more options
3: Seeker
Hi, yes I did get it sorted but it took around 6 calls and then a 2hr call with a really good technical guy! So I understand your frustration!!

It turns out that my price plan had been changed (to correct an issue I had with my entertainment pack a few weeks ago though the guy who did it hadn't told me that was the fix he'd applied) and this had led to a conflict as my old plan hadn't been properly deactivated. So to correct it, I had to revert back to my "old" plan, which was a pain as it looks like I've had to pay additional costs to cover their mistake but it did sort it out.

Hope this helps!


View more options
Moderator (Retired)

Hello @docrox22

 

I'm happy to hear the problem has been rectified. 

 

Hello @TK333

 

Are you still experiencing problems with this? If so, what has our team advised?

 

Louise

View more options
2: Seeker
Yes I'm still having the issue despite numerous assurances it would have been resolved by now. Very frustrated indeed...to summarise:

08/11: I applied for free 1gb data by texting 'DATA' to 97888. Received a message saying this had been applied and when I next tried to use the internet/WhatsApp etc (off wifi) it wouldn't work.

10/11: Called 191 who checked my home postcode & said there was planned maintenance locally which was probably what was disrupting my service - I advised I had been to 3 other postcode areas & had the same issue. They suggested a SIM swap.

11/11: SIM swap completed at a Vodafone store - I was not advised about completing activation online by completing a form (found this out on google) but regardless...

12/11: Still no service off wifi. Went to another Vodafone store who completed a further SIM swap since the first one hadn't been 'validated' (?). They tried my SIM in their phone (I have already tried in old iPhone) & concluded phone & SIM both fine, the problem was with my account so I would need to call 191 again so they could 'refresh' something.
Called 191 and spent 40 mins talking to tech team who tried various things e.g. data refresh, advised me to check mobile data settings etc (I had already done all of this!) - still not working. At 6pm the adviser told me his shift had ended and his cab was waiting (?!!) so I was passed onto another adviser and told to say they needed to "check an open order" on my account.
I was put through to the adviser who had no background details so I had to explain the issue from scratch yet again. After being kept on hold he said he had "completed the open order form to refresh data" & all would be resolved within 1 hour after switching phone off & on again. I asked if he could explain the issue, he said "it was our (Vodafone's) error". Would only give me his first name for my reference.
After 1 hour - still not working.

13/11: Called 191 again, was this time advised there was an "order in progress" which had been escalated but would be resolved by 2:25pm i.e. 24 hours after the last SIM swap. I said this was nothing to do with my SIM card - adviser seemed certain it was despite me explaining all of the above. She sent me new APN settings to install - explained I had done all this to no avail. She insisted all would be sorted by 2:25pm.

14/11: All is not sorted! Still have the same issue with no server connection & unable to connect to internet, use what's app etc when off wifi.

This is incredibly frustrating, not least because I've been told several times that all will be sorted within an hour etc and this just hasn't happened - I'm starting to feel these advisers are saying anything just to get me off the phone so someone else can deal with this another day. And being passed on to another adviser because someone needs to "go home" is dire customer service! The second time this year I have had terrible customer service from Vodafone.

I am sure by accepting the free 1gb my account settings have been affected somehow (not dissimilar to @docrox22) but whatever it is please can this be resolved asap? I also feel some compensation would be appropriate given the time and effort I have spent and the inconvenience (plus I have lost a week's service which I pay for).

I'd be grateful for an update, thanks.
View more options
Moderator

Hi @TK333

 

Thanks for bringing this to us. I've sent you a PM with our contact details, once you've filled it in, we'll be in touch as soon as possible.

View more options
2: Seeker

I appear to be having the same problem.  Agreed upgrade on Friday and account was updated, no issue on existing phone.  Had my account updated on Monday due to dispute so moved from 6gb tariff to 10Gb tariff with entertainment pack.  Phone had arrived so swapped SIM and no internet.  Phoned 191 who changed APN details, but still nothing.  Went back to old phone and still nothing.

Getting full 4G signal in areas that I know are working.


Can someone look at my price plan to see if the same thing has happened when the tariff was updated on Monday?  Was already pretty annoyed about this whole upgrade process before this.  How long is the cooling off period?  Seriously considering going elsewhere. :-(

View more options
2: Seeker

Had copied vodafone in via email and someone has been in touch.

View more options
Moderator

@mupwangle

 

I've sent you a private message with details on how to contact us, please follow the instructions on the link and we'll be in touch.

View more options
2: Seeker

Thanks Carly, however I'd already spoken to the social media team and forwarded them the link to this forum post.  They escalated it to the "back-end" team and the next day it suddenly started working.

View more options
Moderator

@mupwangle

 

Thanks for getting back to us, I'm glad it's now working.

 

If you need anything in the future, please let us know.

View more options
1: Seeker

Folks - having same issue:

responded to txt to remove cap on international roaming. Got Correct txt saying cap removed but cannot access internet since. 

 

Phone is iPhone 6s 

mother sim works in this phone so not the phone.

 

made 10+ calls to Vodafone from Manilla, Singapore and now Sydney. Have re-entered web / internet settings, turned roaming on off, rebooted phone, changed off Vodafone network and back etc but no dice.

 

assune it's highly likely that it's an issue on the plan somewhere as the above folks are seeing.

 

so far today I've been transferred, to dead lines, phoned multiple times for less than 2 seconds, been on the automatic call back system and then when called back waited 20 minutes with hold music...

 

i soend 200-300 a month on this phone and I have a team of 10 internationally travelling sales people using your phones. Right now I'm not rating your service here.

 

being stick out in Asia on the street in Manilla and not able to call an Uber is not cool when the advice from locals is only to use uber / grab for security reasons.....

 

i look forward to soneone sorting this out..

 

 

 

 

View more options
Moderator

I'm sorry to hear you've been experiencing issues with your data @Traveller380.

So we can take a closer look into this, I've sent you a private message with details to contact our team directly.

We'll then be in touch to help as soon as possible.

 

View more options
2: Seeker
Hi Carly, Could you send me the same link?  I have exsactly the same problem; I'm on my seventh call to Vodafone, 1hr duration each time. No data in Europe at all (France, Germany, Belgium, Poland) although full 4G/3G singal. No bars, tried all dignostics - this also started happening when I upgraded my contract. I tried moving my friends Vodafone sim into my phone and data started working . This has been going on for 2 months with no resolve. Thanks, Sam
View more options
1: Seeker

I am having the same issue. Phone says I have 4g, but I get no internet access. I have reset phone, network settings and APN details, but it still doesn't work. Other SIM cards work fine. 

 

Can you help please? 

View more options