main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

iOS

Mobile shows 4G signal but no internet access

Moderator

@Darren66 @samoriordan I've sent a private message to you both with details to contact our team directly. 

We'll be in touch as soon as possible once we receive your details.

View more options
2: Seeker

Hi @Natasha,

 

I have had this same problem since 24/6/17 (on Android rather than iOS though) and am struggling to get it resolved by Vodafone's third level Tech Support. It's been established that the problem is at Vodafone's end, and not phone dependent.

 

I ring to progress the matter but get fobbed off with "Oh it's a 4G issue, we are woring to fix networks in your area."

My husband has one digit number different to me, the same phone model and bundle and his mobile data is fine.

 

Please could you contact me to help as I am despairing getting this sorted after two months!

View more options
Moderator

@TigerTots - I’m disappointed to hear how long this has been ongoing for.

So my team can help further, please send us your details by following the instructions in this private message.

View more options
1: Seeker

I have the same issue in the USA. Phone says 4 G strong signal.   Tried resetting everything.

 

Phone worked fine for data roaming in Italy last week and Germany week before. 

 

I had a text from Vodafone telling me I am in one of the roam further destination so I can use myUK plan for £ 5 per day.

 

tried ringing 191 which was less than useless as the menu option 4 for problems abroad ended up trying to sell me Vodafone international. 

 

Last time in US 3 months ago I had no problem. 

 

 

View more options
Moderator

@terrier15 Please unsure your phone is set up to use whilst travelling abroad.
Does the issue still continue when you switch your phone to 3G? - You can do this in the settings of your phone.
It may also be worth speaking to our Live Chat team to check everything is as it should be on your account.

View more options
2: Seeker

This problem has started happening to me since Thursday 23rd. I'm on a £10 big value bundle and my data ran out a day before the bundle ended. I text the number to renew my bundle early which all went through, if I call 2345 it tells me my bundle is active with data available, but I can't actually use any data. No websites or apps that use data will load. I have a 4g icon showing I'm connected, and I've tried my SIM in a different phone and a different SIM in my phone to confirm that it's a problem with my SIM.

View more options
Moderator

We'd like to look into your data for you @ColonelOfTruth.

So we can do this, I've sent you a private message with details to contact us directly.

A member of our team will then be in touch to discuss this further.

View more options
2: Seeker

Am sadly having exactly the same issue. Phone will not allow me to access mobile network option under settings, more. Instead displays no service message despite having Vodafone UK displayed with 4G. Any help rectifying this would be greatly appreciated

 

View more options
Moderator

@Viking409 Could you please provide more information on the error you're receiving? - Feel free to send over any screenshots 
We'll then be able to advise you further.

View more options
2: Seeker

Hello

In a nutshell I cannot access the option to turn roaming on or off on my HUAWEI phone. Normally I would enter 'settings' - 'more' - 'Mobile Network' and be given the option to ammend the functions I need. As it stands when 'Mobile Network' is selected instead of opening an options menu the signal bars at the top right of the screen blink out (replaced with a an icon with '!' at its centre), the Vodafone service indicator at the top right of the screen displays 'No Service', and the 'Mobile Network' page refuses to open.

 

I can still use WI-Fi and at the moment it seems that 4G may be be working although only through the drop down menu on the home screen.

 

Have restarted, set. Reset internet settings, tried sim in different handsets. Stuation not exactly critical as it is not affecting my phone usage, but would still like to know why I cannot access the 'Mobile Network' page.

 

Thank you for your speedy reply, and any help in this would be appreciated.

 

Regards

Mike

View more options
Moderator

@Viking409 How strange. So we can investigate this further for you, please confirm which model of Huawei phone you're using.

View more options
2: Seeker

Hi Natasha,

I'm having similar problems with data roaming.  Everything was fine until about a month ago when I returned from a trip to UAE, since then data roaming has not worked (Italy, France, Netherlands).

I've spent a while on live chat, conclusion was to call the Tech Team.  I then spent abnout an hour on the phone with the Tech team, only to be told (incorrectly) my monthly data allowance was almost used up.  I then got passed to the Account team who investigated and told me I had almost all my 20GB allowance left and so that wasn't the problem.  After more investigation, some indicator was found on my account that was blocking service due to my large roaming calls bill from UAE even though the bill had already been paid in full by the usual direct debit.  I was told to take out my SIM and restart in a couple of hours and it would all work.  I did this, restarted the phone several times, but data roaming is still not working.  Can your team please help me resolve this?  I need to get it sorted for my next business trip next (next week).

Thanks!

View more options
Moderator

@marathon811 It sounds like your spend cap was triggered by the large charges raised whilst you were in the UAE. This will only remain on your account until the direct debit has been received.

As this is an account related query, we'll be unable to assist via the community. So we can help you further, please reply to the private message I've sent you.

View more options
2: Seeker

Hi Mark, many thanks for the reply!

I was in contact with the support team 6 days after the direct debit was paid, so surely the cap should have been removed by then?

Thanks also for your PM, but the link to follow-up was missing from the message, could you re-send this to me?

 

Thanks again.

View more options
2: Seeker

Hi Natasha, I’m having exactly the same problem (4G shows working but no data) in France. Can you PM me please to get this sorted?

 

thks

View more options
Moderator

Thanks for getting in touch with us @Radiomir.

I've sent you a private message so we can look into this with you. 

View more options