Showing results for 
Search instead for 
Did you mean: 






Unfortunately ims framework has stopped

1: Seeker
I updated my phone to lollipop and I keep getting the above message every few seconds. Help x

16: Advanced member
16: Advanced member
Have you performed a factory reset since the update ? If not I would recommend doing that. Make sure you back up your data first.


2: Seeker
2: Seeker

Hi Talulah


I had the same problem. Here's a fix:


1. Open 'Messages' (SMS app)

2. Go to 'Settings' in the top right (you need to scroll down to see 'Settings' from the options, as the defaul pop-up window isn't big enough to show all of them)

3. Select 'Default messaging app'

4. Select 'Rich Communications'

5. Uncheck the 'Rich Communications' box


This has stopped the 'Unfortunately IMS...' message appearing every few seconds on my S5.


Hope this works for you, too.

Updated last night same problem spammed to death every 3 seconds made using the phone extremely awkward.


Did a hard reset still got spammed with IMS stopped and now i have to reset up my phone 😠


Tried Diamat solution and that worked (thank you so much)


However its not a fix but a bandaid I would be nice to see a solution from VF

Hi. i can find the option in my messaging app but when i select the option to diasble rich communications then press the ok button it automatically reverts to it being ticked again , resulting in still having this problem. Any help would be greatly appreciated. Many Thanks

In messages click the 3 dots (top right), select settings -> default messaging app -> rich communications  and uncheck the box for rich communictions



Am I the only one. Extremely suspicious of this feature. An installed app. That cannot be removed. That uses 20% battery power. I want this removed from my phone. I did not ask for it. I will not use it. And! I want to know what else this app is doing to use so much battery power 24/7. Vodafone, what else are you hiding in this app. And what gives you the right to force a product without the option of removal. My battery life is rubbish since this install. Kindly get rid. Or does the question have to be asked of the regulator?

Community Manager
Community Manager

Hello @traveller1 


You're not able to remove any apps that have been installed as part of a firmware update. 


If you're having issues please preform a factory reset, remembering to back up any stuff you don't want to lose. 


Please follow the fix above, if you're getting the same error message. 







This is the 2nd time in 6months that I have had this issue 9and I've only had the phone 6months!), clicking the rich communications box doesn't work as it always re highlights itself. I had to do a factory reset last time I had this issue and I am not impressed with having to have to do it again. This phone is turning out to be more hassle than it's worth at the moment and the service from vodafone is shocking!

1: Seeker
Thanks so much for this tip! The message started appearing on my phone all few months ago but only when I went to read texts. But recently it's been appearing all the time, so glad it's stopped! 🙂