Showing results for 
Search instead for 
Did you mean: 






Possible IPV6 bug in Vodafone Wifi hub that impacts Android devices

2: Seeker
2: Seeker

Hi. I think I've found a bug in the IPV6 implementation in the Vodafone Wifi Hub that seems to only impact Android phones, that has been cause lots of connectivity problems on the Android devices connected to my home network. The connectivity issues have been driving me nuts since December when Vodafone started issue me an IPV6 address for my home broadband. I've also come up with a work around solution that allows me to keep IPV6 enabled on my network. but no longer impacts my Android phones. I'm writing this so that hopefully someone at Vodafone will see this and can investigate the router firmware, but also so that it might help others out if they experience a similar issue. Okay, so here goes...

So Vodafone allocate a /56 IPV6 address space to my home broadband connection, such as 3c4d:abcd:1234:f900::/56. That isn't the actual IPV6 address I've been allocated, but will do for this example.

Out of that /56 block, the router allocates 3 iPV6 subnets as /64 blocks:

3c4d:abcd:1234:f900::/64 - This is used for the WAN inferface for the global IP addresses
3c4d:abcd:1234:f901::/64 - This is allocated to the main internal network
3c4d:abcd:1234:f902::/64 - This is allocated to the Wifi 2 network, ie. the guest network

I actually have Wifi disabled in the router, as I instead have a seperate set of Wifi access points plugged into the ethernet port of the router. My Android devices connect to the Wifi access points and so all traffic is coming into the router via Ethernet. However even though Wifi is disabled, the router still allocates all 3 subnets internal, from what I can see on the Status page when logged into the router.

So when my Android devices first connect to the network, they get 2 IPV6 address in the subnet 3c4d:abcd:1234:f901::/64 for the main network. I know Android uses SLAAC for IPV6 allocation, so it isn't strictly the router handing out the addresses, but it does provide the subnet prefix. Anyway, every thing is okay so far.

However a few minutes later, the Android devices also get 2 extra IPV6 addresses in the Wifi 2 subnet of 3c4d:abcd:1234:f902::/64. This even though they are only connected to the main network (via my Wifi access point and ethernet into the router itself) and I have all Wifi on the router itself disable. This is when the Android devices start having connectivity issues. I believe this is because then the Android devices are trying to use that extra set of IPV6 address for the connections they are making. The router would obviously only route traffic coming back to IP addresses in the subnet to the Wifi 2 network, and so the Android devices don't see the returning traffic hence causing the connectivity issues.

My work around that I discovered last night is to go into the router settings and go to the Settings --> Local Network page. On there I disable IPV6 just on the Wifi 2 section and then save that change. If I then disconnect my Android devices from the Wifi and reconnect, they get allocated the first set of IP address on the 3c4d:abcd:1234:f901::/64 subnet, but the second allocation, that used to happen a few minutes later, for the subnet 3c4d:abcd:1234:f902::/64 that is supposed to be for the Wifi 2 network, then never happens. Everything then appears happy.

I'm not quite sure why, if when IPV6 is enable on the Wifi 2 network, this allocation of IP address on the 3c4d:abcd:1234:f902::/64 subnet only seems to happen on Android devices. We have 2 Android devices on our home network and it happens to both of them. My Windows devices and iOS device aren't impacted. They always only get IP address on the main network 3c4d:abcd:1234:f901::/64 subnet.

But I think it is a router firmware bug, as I don't think that a device connected to the main network, whether by Wifi or by Ethernet should even know about the Wifi 2 network 3c4d:abcd:1234:f902::/64 subnet.

Anyway, I hope this helps someone at Vodafone to dig deeper, or for others having a similar issue.


2: Seeker
2: Seeker

I forgot to add, this is on Vox3.0v type router, running firmware 19.4.0551-3261143-20231024185100-7efccd9e333e995b72430e4ef45c0f27f265fb5d

16: Advanced member
16: Advanced member

We've been well aware of IPv6 issues for a long while now, but it's good to have your perspective on this. 

16: Advanced member
16: Advanced member

Just to add, any IPv6 addresses starting "fe80" are not public, They're Link-Locat addresses just like

4: Newbie

Ouch... Can't wait to see how this will affect me once my connection will be live in a few weeks... Any way to solve this issue?

Disable IPv6 on the router if you have any problems with it. 

Maybe I should've gone for that BT retention offer of £45/month haha

Hi. Yes, I wrote in the original comment how to work around it. Disable IPV6 on just the WiFi 2 network in the router and leave IPV6 enabled in the main network. IPV6 now works okay for me in that config. Cheers.

nice one! will check that once my VF connection gets connected :Smiling:

I will actually just use the VF router for wired connections... For WiFi I've got my Unifi setup :Smiling: