Showing results for 
Search instead for 
Did you mean: 






Wi-Fi extender

2: Seeker
2: Seeker

I hope that someone can help, Vodafone Broadband App is not working and I am trying to connect a Vodafone wi-fi extender to the hub. I already have managed to connect an AP wi-fi extender and it works fine for static devices like TV's .

Vodafone fast 286 will connect to the router using WPS but no mobile devices can connect to the extender. I can not find any manuals, instruction on line either, everything recommends the Vodafone App which is out of circulation.

Any help is hugely appreciated. 



16: Advanced member
16: Advanced member

Why is the app not working, that is the official method of configuring the extenders?

I have the same problem whilst the powerline shows a strong WiFi signal it will not connect my laptop to the internet. Tried TP and Solwise powerline exenders.

Because it has a bug in it and Vodafone has not got a fix ! Been offline for 3 weeks.

Hi @Worrybeads I'm sorry to see you haven't been able to get this resolved after so long. I'd recommend giving our WiFi Xperts a shout on Live Chat or catch them on 191 free from a Vodafone mobile or 03333 040 191 to look into this further.

Hi, I have tried today over an hour chat with a member of your team and refusing to transfer me to an expert. After an hour of chatting, I am exactly where I was before the call. broadband app does not work, wi fi extender connects to the router, but without the App I am stuck. According with whomever I was on chat with there is no workaround the App. He had no idea that the App needed to be fixed and refused to look at his knowledge base.

This is now a comedy of errors!!!! 

16: Advanced member
16: Advanced member


The OP has problems with the Vodafone supplied extenders, which need the app to configure them.

If you are using 3rd party extenders, you need to follow the instructions that come with the devices.

If you really can't get them to work, perhaps start your own thread, and maybe someone can assist.

My first thought is that the cable connecting the extender(s) to the Vodafone router may be faulty.