Showing results for 
Search instead for 
Did you mean: 






Onenumber - esim swap disaster

2: Seeker
2: Seeker

I moved from Three a week ago in order to use smartwatch pairing services as Three can't tell an esim from a fried chicken and their support has literally been the worst I have experienced in a very long time.

I struggled with them trying to add watch pairing for four months but they just do not know what they are doing and after being with them for 15 years, left and made the move here.


Got my number ported, account setup, added my watch to onenumber - no issues.


Until today. My watch developed an issue and needed to be replaced. New watch arrived today, got it setup, logged into my account and found an obvious place to swap the esim from the old watch to the new watch.


Game changing. Three are still whittling wood, and Vodafone have this feature available for us to self-service.


And then I tried to use it.


It does not work. At all. Supplying the new EID results in an error message. Trying to request a QR code, results in the same error. Typing the EID into a text editor without a space padding every 4 digits and copying it back into the EID box to see if that was an issue made no change - still the same error message "Sorry - there seems to be a problem. We're sorry, but something went wrong.".


I logged into Onenumber to try to remove the device so that I can add the new one, but when doing this, your are told you must contact support.


The live chat never works, it permanently says all agents are busy and never connects you.


TOBI is junk, so I had to resort to calling, already knowing this was probably going to be a disaster.


It was. Support were not really prepared to listen to me and kept insisting that they were right. I am a highly technical person and have worked in networks and mobile networks for over 30 years now so I am not new to any of this.


They insisted on sending me instructions by text which took 20 minutes of being on hold for them to find these instructions. When they arrived, they told me to do what I'd already done that does not work. Support were not interested in this and insisted I did it again.


I did and gave them the error message. They still somehow seemed to not believe or understand me and pretty much told me I was wrong. I understand they have a script to follow, but they plain do not believe you when you tell them that what they expect to happen (because that's what their script says will happen) is not happening.


I asked if I could be transferred to technical. I was told I would be transferred and got put on hold for another 20 minutes. After that, support came back on and asked if there was anything else they could do. I asked if I could be transferred to technical as I had been on hold for 20 minutes. Support told me I had not asked to be transferred to technical and had asked to be placed on hold. God knows why anyone would ask to listen to 20 minutes of that garbage annoying music, and that is certainly not what I had asked for.


I asked again if I could be transferred to technical. I was told they would do that straight away.


After another lengthy hold of around 15-20 minutes, support came back and asked if technical had solved the problem. I explained that I had been on hold again and had not yet spoken to technical.


I was put on hold for a few minutes. Support came back and told me that now everything was sorted out and I just needed to restart my devices.


I explained that that would not help as they could not have fixed anything or transferred the esim as I had not given them the EID of the new watch. They were disinterested and told me that technical had said that this was "now all just a matter of connection" and that all devices needed to be restarted and everything would magically work.


I tried to explain another few times that nothing had changed, my old watch was still in my account showing the old EID and IMEI and restarting would not fix this. Each time, I was told again that the issue was "just a matter of connection" and I must reboot everything.


I gave up after a few minutes. Rebooted everything to check, but obviously I am no further forward as nothing has been changed, the esim swap function on the website doesn't work, support are not prepared to listen and also did not seem really to have a clue what they were talking about. Although they did try to sell me a new watch during the call. Apologies support that you missed out on that commission.


I genuinely believed that no other company could have support as obtuse and useless as Three, but Vodafone may be well be on the way there.


Is there anything I can now do with this? I have a monthly onenumber I am paying for and can't use. I also can't cancel it and transferring a sim from one EID to another seems to be nigh-on impossible.


I'm sure that, as with most companies, there is one lowly tech who actually knows what to do and how to do it on their backend, but I cannot spend another 4 months on the phone endlessly as I did with Three (some calls were well over 5 hours to get nowhere) in the vain hope that this time, I will manage to get through to that person.


Is anyone aware of a route to somebody in some team, somewhere, who is not as much use as a bra on a snake and can actually assist me in making this very simple change?




Hey @Konkeydong Thanks for reaching out to us. 

So that we can help you with your Apple watch, please reach out to our Social Media team on Facebook or Twitter. They'll be able to investigate the issues you're facing and help to get it resolved.

Thanks Callum, I have already engaged with them based on what others facing the same problems have said.

It does seem like the platform itself has a problem though.