Showing results for 
Search instead for 
Did you mean: 






Esim swap

2: Seeker
2: Seeker

Have just tried to swap Esim to a new Apple Watch 8.Went in to app, settings, account,swap sim, select secondary device, Apple Watch. No matter how many times I enter the Eid, it will not highlight next and I can go no further.


4: Newbie

Same issue here. SIM Swap form for Apple Watch lines has been broken for months now. I reported it twice already. It will either say “Something went wrong” or it will have the issue you describe where it won’t let me submit  the EID at all. I mean the fact that we have to go through this process instead of Vodafone integrating with the native Watch App process is enough of a sad reality on its own. 

Its sad they do not acknowledge an issue with the web form. My reference was 187290869791984830 but nothing ever came of it. 


For anyone having issues with their eSim the only solution I found was to end my OneNumber contract through live chat. I gave it a day and then signed up again through the iOS watch app. The sign up process does work correctly. 

You can also give 191 a call, ask to speak to the technical team and then have a way of completing the sim swap on their end - you just need to provide the EID. This is what I have been doing. 


For me this issue keeps repeating.  It works for a while and then my watch loses connection and I have to re-add which I’m unable to do myself so I have to battle through being told by Vodafone multiple times to factory reset my Apple Watch.  It’s very frustrating that I don’t know my watch doesn’t have a connection until I try to use it.  Any better solution yet? 



2: Seeker
2: Seeker

The SIM swap form has not been working for ages, if ever, for the Apple Watch. Long story short I have probably tried to fix the Apple watch plan with Vodafone a dozen of times. It only works for a short period of time and then it stops. No option to fix it via the website since the submit button is grayed out. The support is unable to fix it properly as well. I suspect Vodafone is currently not able to make the Apple Watch work properly with its service in the UK.

On a positive note, I also have Google Pixel Watch which works OK with Vodafone 4G. The sim swap is working OK as well using the QR code.


Today due to the data plan having disappeared from the watch again I did the SIM swap using the Vodafone app and choosing the Other Watch instead of the Apple Watch. I was surprised to see the SIM swap through OK. Perhaps this is a workaround for now.

Other users seem to take this route as well.

NB. The 191 support was not able to do SIM swap for me a couple of days ago for an unknown reason.