Showing results for 
Search instead for 
Did you mean: 






Ethernet connected device not showing in UltraHub connected list

2: Seeker
2: Seeker

My Fire TV is connected to my LANetwork and is working fine - is connected to internet, but is not showing up in list of connected devices in Ultrahub - I'm trying to fix / reserve as many of my Ivp4 addresses as I can and obviously can't do this for the Fire TV if it doesn't show up with an allocated Ivp4 address- within settings of FIre TV clearly says wired connection. Thanks for any suggestions GrantdF


16: Advanced member
16: Advanced member

What ip does your fire tv say it has. You can set that as a static ip on the fire tv itself. 

What problems would it cause if it was left to dhcp though? 

Hi Ripshod - thanks for taking an interest and the time to respond to my problem - as stated I'm trying for simplicity and reliance to fix / reserve as many of my device IPs as I can and am easily able to do this within the expert setting of the LAN by picking up the devices from the drop down list within the Static DHCPv4 list but it will only let me add (+) from this list and I cant input the mac address and IP directly manually (which i found from the FireTV 'about' in settings - the Fire TV confirms its connected to 'wired' network and obviously works - would shortening the lease time (currently set to Forever)  force the Fire TV to poll the router make it show up ? as powering it on/off and or unplugging ethernet cable from the FireTV didn't make it show up in network list in the UltraHub -neither did restarting the UltraHub -  it does show up on my FING phone app and has indeed changed its ip from .111 yesterday to .112 today --- probably on one of my power cyclings ?? - any ideas how to set this as a static IP would be appreciated - BTW - I couldn't see an option within the FireTV settings to make the IP static as you suggested - am I missing something there ?? thanks again yrs Grant