Showing results for 
Search instead for 
Did you mean: 






THG3000 router firmware out of date

4: Newbie

My router is currently on firmware version 19.2.0307-3261013


I'm having problems with cloud streaming on the Xbox and I wanted to eliminate the firmware as being at fault as it's quite a long way behind the latest release.


Doing a manual update check fails after 5 minutes, is there any way you can push the newer firmware to my router?


16: Advanced member
16: Advanced member

Vodafone don't give out information on the latest firmware (as  far as I know). If you contact them they may be able to do what you want, but nothing will happen through this forum.

I believe I have managed to trigger a firmware update in the past (it may just have been a coincidence I suppose) so try this:

Disconnect the router from the net. Do a factory reset of the router via the firmware settings. After it has fully rebooted, reconnect it to the net. With any luck it will connect up and then reboot again after updating the firmware.

If you do try it let us know if it works for you.

Good luck.

2: Seeker
2: Seeker

try to reset your router. After reset will be updated to latest firmware 

Anyone know what the latest firmware is? It might be useful to have a thread posting this as my router never updates without a factory reset which is not something I do very often.

Surely vodafone should have fixed the check for update page after all these years but mine has never worked.

16: Advanced member
16: Advanced member

I believe the latest is 19.4.0551-3261103, at least that is what I have, and mine updated not long ago.

Time to update... Thanks very much.


If someone could post when a later version than this is released it would be much appreciated.



I'm having similar issues with the Super Wi-Fi Booster tile not appearing within the Vodafone Broadband app. Though I may have found a solution that I hope will help you, or at least others who land on this page and are reading this, desperate for a fix to the issue. If you haven't updated the Vodafone Broadband App though, please do this first before following my advice below.


On a laptop/desktop or any other PC (not a mobile device/tablet/smartphone) open your usual internet browser and enter into the address bar and it'll allow you to login to your router, giving you access to it's settings. You will need your routers' password which can be found on the information sticker on the bottom of it. You'll see your network and password information on the left with the QR code to quick connect from your phone etc (you may have already used this to get your devices connected) but to the right you'll see the IP address I mentioned above then your unique router password below it. The IP address will be in bold.


Enter the password shown into the prompt/box that comes up on screen within your browser and it'll log you into the router (please bear in mind this is case sensitive). Once logged in you'll see several tabs with a red background (Overview, Internet, Wi-Fi, Sharing, Settings then Status & Support) but above that will be a grey bar with a drop down menu top right. Click that and switch to 'Expert Mode'. This will give you additional options - one of which will be 'Firmware Update' which can be found under the red settings tab. It's the second option below password.


Click the Firmware Update option. It'll allow you to check for an update and let you know if one is available. This will take several minutes and it may temporarily disconnect any connected devices until it finishes the update - they'll automatically reconnect though. Please note that unless you're sure on what all the other settings and options mean - avoid messing with anything else as you may get disconnected or change the set up of your router and any further settings changes should be done with guidance from an expert (whether that's Vodafone or another third party). Though checking for a Firmware Update is pretty straight forward using this option and you won't cause any harm.


Let me know if this worked for you. 

Unfortunately that’s the procedure that always comes back saying no firmware is available but when  you factory reset the new firmware is found and installs. It’s clearly a long term bug vodafone developers can’t resolve which leaves countless people with insecure firmware. I’ve had 2 of these routers now and both were the same. The firmware was 2 years out of date before I realised that the checking procedure above didn’t work. When I factory reset the unit I jumped 3 or 4 firmware versions. I also find backing up the settings and restoring them after an upgrade never works either which makes the process even more painful. 

Is 19.4.0551-3261103 still the current version as it’s probably time I checked again?

16: Advanced member
16: Advanced member

@sat505 that is the latest firmware as far as I know.

@jamesnemo90 the firmware update option has never worked for me, I'm pretty sure it is totally broken.