Showing results for 
Search instead for 
Did you mean: 






Vodafone router with Velop mesh for WiFi

4: Newbie

I have the following set and something recently has changed which is causing me grief.

This is the connection chain.

OR FTTP Modem - Vodafone Router - Unmanaged Switch - Velop Nodes.


The Vodafone router is plugged into an Unmanaged switch using one of the Ethernet ports. WiFi on the Vodafone router has been switched off. 

The Velop nodes are all plugged into the Unmanaged switch via ethernet cables. This means that the Velop Nodes are operating with a wired backhaul. 


What is happening now is that if any client connects via the main WiFi connection on the Velop, they are connected to WiFi but without Internet. e.g. the client gets an IP address of

But if any client connects to the Guest WiFi they get Internet but then they are on another subnet range. e.g. IP address is


What I think is happening is that the Guest Network NATs the clients to the Node IP address. The Node is sitting on the LAN and hence has Internet access. All my other wired devices have Internet access.


So what is stopping my WiFi clients from getting Internet access and being put into the same Subnet as the Vodafone router and getting an IP from the DHCP pool? e.g. 192.168.1.x



New theory, and bear with me on this.


In my quest to end my insanity I found the following page.


Here too the person reported getting the addresses but it came from the most unusual source, a CCTV camera!


So I went and disconnected the security cameras from the switch and it's too early to claim victory but I think one of them has suddenly started running a rogue DHCP server on my network. Its issuing out the same address to any new DHCP requests, and that results in an IP conflict. And because its sitting on the switch, it's only affecting clients trying to connect via the switch onto the main network.


I will definitely come back and report if I feel this has been my issue all along.

Another example of a camera playing havoc on the network.

So I am finally back up and running after nearly 5 days.

It wasn't the Velop, it wasn't the switches, it wasn't the VF Router. It was simply one of my CCTV cameras has suddenly decided it wants to be a dodgy DHCP server too.

The camera had a fixed IP itself so was working fine on the network.

But for some reason It has created a rogue gateway of but it was dishing out just one IP address of to any clients making a DHCP request.. Multiple clients were then detecting an IP conflict and then retrying. 

This caused havoc on the network and my switches were simply doing their job I.e. sending the requests through.

Guest WiFi clients were fine because they make a local DHCP request from the Velop node. 

In the end it was DHCP related but not what I expected and definitely not where I expected to find it. 

Moral of the story, disconnect every cable from the switch before blaming the switch. Never once did I suspect something this stupid would causing me so much grief. The joys of OEMs using Linux in their devices and not removing the packages they don't need.

16: Advanced member
16: Advanced member

@bruce_miranda  It may be that the OEM does this for end-users to setup with something like a laptop directly connected. 

Good to hear that you have finally got this sorted out.

You may want to replace that camera. The dhcp symptom is one that points to a possible trojan. 

Nah, just replace it so this doesn't happen again. 

16: Advanced member
16: Advanced member

@Ripshod  "Trojan" haha, you should have seen a Samsung TV I once had. When probed it had 20 open ports with services attached. 

16: Advanced member
16: Advanced member

So glad it's solved. I really hate an unsolved mystery.

Probably the camera has dropped in to some setup mode where you can connect directly to it without a network.

If so go in to its settings and you can probably turn it off.

I have aged 5 years atleast in the last 5 days trying to find what suddenly caused it. My poor parents feel like I am blaming them because it's only when they visited us last week and decided to connect to my WiFi that this nonsense started. All the other clients in the house have been given out Forever IP addresses by the DCHP so weren't affected. But the moment a new client came along they got no Internet, in this particular case restarting the equipment was the worst thing I could have done because suddenly all devices started requesting a DHCP address and was being served by this camera!!

I have gone back to the documentation of the camera and something is still not right. It does however say the camera can use a gateway of in order to make a direct connection to it from a laptop. It then says to assign the laptop a static IP of and then access the camera using the camera's default IP address of 

However what I was seeing was that the camera was handling out it's own default IP address to other clients on the network who were requesting a DHCP IP address. I still cannot explain that bit. Maybe time to reset the camera, bin it or do both!

16: Advanced member
16: Advanced member

@bruce_miranda wrote:

none of the clients are able to request an IP for themselves. 

Did you not say earlier the main wi-fi devices were getting a gateway of Was that not provided by DHCP?