main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

iOS

Moved number, V-V (visual voicemail) gone (eSIM second line)

zpjet
2: Seeker

Hi, I got onboard Vodafone two days ago, via eSIM as my second line with a temporary number.

My primary line doesn't have V-V, but I was very happy when I saw Vodafone's V-V working right away and seamlessly - I just got a SMS that you now have Visual Voicemail on your phone, indeed the interface was there, I tested it and it worked. I called the number from another phone, left a message, it showed up in V-V.

Then I ordered my number to be transferred from EE (which also had V-V) to VF. It happened yesterday, and whilst everything else works (i.e. both lines have iMessage), I cannot make V-V working. It has Call Voicemail button but that dials my primary line voicemail.

I went through instructions thoroughly, including section what if it still isn't working for me, and then I called 191 and we went through resetting the voicemail on the number, but it didn't work. I tried the instructions again, to no avail. I even tried to Reset Network Settings which let me choose the data plans again - I tried to use VF as primary line, I turned off Wi-Fi, used data... Looks like something is stuck - and unfortunately there's nothing in iPhone's Settings to un-stuck it. I suspect that somewhere there's still my temporary number linked with V-V and so I cannot get it on my original one.

Any hints? Thanks!

View more options
1 REPLY 1
zpjet
2: Seeker

OK I got one more idea and it worked.

Instead of what I tried many times - switching what is my default mobile data or voice line - I just disabled my primary line.

Immediately (in a matter of seconds) I got a text Great news! You now have Visual Voicemail on your phone. And indeed I do.

I tested it and then turned my primary line back on but the V-V stayed.

It could be a pure coincidence but if you do have issues with V-V on the secondary line then go to Settings > Mobile Data > Data Plans > [primary one] > Turn On This Line > [off].

View more options