Showing results for 
Search instead for 
Did you mean: 






Getting eSIM to work on my new Google Pixel 2 smartwatch

2: Seeker
2: Seeker

Hi All,

I've recently purchased a Google Pixel 8 Pro and a Google Pixel 2 LTE smartwatch from the Google Pixel store.

I was with 02, but then I learnt that 02 aren't a supported network for LTE smartwatches. Only EE and Vodafone are in the UK (at time of typing, Oct '23)

So now I'm with Vodafone.

I've got the eSIM setup on the Pixel 8 Pro phone, no problem.

I've signed up to the £7.50/month Vodafone OneNumber service.

But I've can't seem to get the eSIM setup on my Pixel 2 watch.

I've just been on a >1 hour tech support person from Vodafone, and they were convinced that everything was (eventually) setup correctly. We did all the usual things, like factory resetting the watch after unpairing it from my phone, etc. etc.

But now I've moved my watch away from wifi and bluetooth... it's not getting a 4G/5G signal (I've got no connectivity), proving that the eSIM is *not* correctly setup on my watch yet,

Has anyone successfully setup a Google Pixel 2 LTE watch with Vodafone? Was it smooth for you? Any ideas for me?! 🙂


2: Seeker
2: Seeker


I've now got it working.
I'd like to tell you exactly how I got it working, but I'm not sure.

It felt like I was going around in circles... and then it just worked.

I knew it definitely worked when I saw, on my watch (at last!) that it was actually downloading the eSIM from Vodafone.
This was after I'd gone into the Google Pixel 2 App on my Google Pixel phone, selected 'Mobile Network', and then I think I click on Manage SIM, and clicked through there into Vodafone.

Again, I can't remember what exactly. It was nothing I hadn't tried before. Maybe there was some sort of delayed setup at Vodafone's settings. No idea.