main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Phone audio no longer routing over Bluetooth in car for anything other than phone calls.

SOLVED
View solved solution
hrym
17: Community Champion

In a quiet moment, I did a bit more digging and found this.  It isn't specific about what problems it refers to or fixes, but there's a simple and non-destructive procedure (clearing the cache) that might be worth a try.

View more options
Digsy
4: Newbie

I have tried that already but I think I may try it again while also deleting the car form my phone and the phone from my car at the same time.

 

Also, do you know if there is a way to completely reset Google Assistant back to default so it is like I am using it for the first time again?

 

View more options
Evie
Moderator

Good idea @Digsy, give that a go and let us know how you get on!
In regards to your Google Assistant, I've had a search on Google and can't find an definitive answer as to whether it's possible to factory reset it. However, I did locate this Google Assistant forum which asked the same question and gave a few troubleshooting steps to try 👍 Hope this helps!

View more options
Digsy
4: Newbie

FIXED!! At least for now.

 

I followed Evie's link to the Google Assistant forum and did these two operations (I don't know which one actually fixed the issue).

 

Cleared the Google (G) app Cache
Open your phone's Settings app.
  1. Tap Apps & notifications.
  2. Tap the Google (G) app. If you don't see it, first tap See all apps or App info.
  3. Tap Storage & cache: Clear cache

Uninstalled all updates to the Google app:

Open Google Play Store > search for Google (G) app > open app > Uninstall > OK > Update > wait for update to install > Restart phone (NB a restart was not necessary in my case)

This caused Google assistant to reset itself, although it seemed to retain some of my settings. 

 

After doing this, it worked in my car as previously. I then did the following additional step of disabling auto-updates to the Google app:

 

  1. Open the Google Play Store app 
  2. Tap Menu  > My apps and games.
  3. Select Updates
  4. Select Google from the apps list
  5. Click the "three dots" menu (top right)
  6. Un-check auto update.

Thanks so much everyone for your help! Hopefully this will carry on behaving from now on. :Smiling:

View solution in original position

View more options
hrym
17: Community Champion

Glad to hear you're sorted.   I'm also interested to hear that you can apparently turn off auto-updating for individual apps - I'm pretty sure that this was previously only available globally.   When you get updates, Google will appear on the list (afaik), so make sure it doesn't get selected accidentally.

View more options
Digsy
4: Newbie

Well... This worked just great until last week when my phone started telling me that in order to continue using some features of the Google app I *had to* update it. So I updated it and the issue with my car's hands free features came straight back. Luckily I was able to uninstall the updates again but now it seems I have to choose between limited functionality on my phone versus limited functionality in my car. Way to go, Google. :Sad_face:

View more options