main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

WiFi Calling on Samsung Galaxy A52 5G

DylJones8
2: Seeker

Hi

I have recently taken out a new contract with a Samsung Galaxy A52 5G. Unfortunately the Vodafone signal in my house is terrible so I looked into WiFi calling. 

It seems that while there is a guide for enabling it, the option to do so on my phone just isn't there. I've checked and there are no updates to be installed. Is it just not available on this phone? Seems strange when older models are listing it as an available feature.

 

Can anyone advise?

 

Thanks!

 

 

View more options
5 REPLIES 5
BandOfBrothers
17: Community Champion

It's not listed as an eligible phone in wi-fi-calling but we have known un listed phone's to work before.

Check it's activated in your myvodafone.

Ask the agent to force the phone via sending an OTA configuration update that should provision your phone for Calling Over WiFi.
Register for Vodafone Wi-Fi Calling
Text the word CALLING to 97888
This is a free text which will add the service to your account
You should receive the following confirmation text:
Thanks. We’ll add Wi-Fi Calling to your account in the next 24 hours and will let you know when you’re all set up.
If you’d like to discuss this with us, or if you have any other issues, you can find more info here or contact us
Once you receive the confirmation text, switch on Wi-Fi Calling in your settings
Go to <span;>Settings<span;>, scroll down and choose the Application icon >Choose >Phone<and scroll down until you see >Wi-Fi Calling< select the box beside this option
A pop-up will appear asking you to confirm if you want to enable Wi-Fi Calling – tap OK"
Make sure Calling Over Wi-Fi is turned on in your myvodafone.
Calling Over Wi-Fi will only activate when there is no network connection. Test by activating Flight Mode on your phone.

Current Phone >

Samsung Z Fold³ 5G.

Previous Phone >

Samsung Note 20 Ultra 5G - SM9860.

View more options
DylJones8
2: Seeker

That's brilliant, thank you!

I've checked MyVodafone to confirm it's enabled on my account (it was already), sent the text, had the 'We'll add Wi-Fi calling...' message. Once I get a follow up message I'll test it and reply here.

 

Thanks again!

View more options
BandOfBrothers
17: Community Champion

Awesome @DylJones8 

 

Fingers crossed all goes well. 

Current Phone >

Samsung Z Fold³ 5G.

Previous Phone >

Samsung Note 20 Ultra 5G - SM9860.

View more options
DylJones8
2: Seeker

Hey!

 

Just thought I'd update, I had no follow up message from VF and the setting still does not appear to enable on the phone.

Does anyone have any other thoughts?

 

Thanks

View more options
BandOfBrothers
17: Community Champion

We could be back to the situation that the model of phone your using isn't on the eligible list @DylJones8  :Sad_face:

Current Phone >

Samsung Z Fold³ 5G.

Previous Phone >

Samsung Note 20 Ultra 5G - SM9860.

View more options