main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal


wi-fi calling: continuous notifications it's available - how to stop it?

2: Seeker

Just to bump this thread. Whilst I have also managed to disable the sound...I am unable to remove the banner from my notification draw. It seems to sit there permanently telling me WIFI calling in on. I know this, because I turned it on. I also have the extra icon along the top of my screen.


There seems to be no way of hiding this banner, has anyone else managed to?


I am on a P20 Pro.

View more options
4: Newbie

I've had to switch on wifi calling because my sure signal packed up and in any case Voda are withdrawing the service.  After a couple of hours of regular notification beeps every 3 or 4 minutes no matter what I did in settings, thanks to Marky wb above.  Silly of me to think of it as a notification, it's a reminder!  Who knew, and who would have though that a user would have found a solution that seems to have eluded Vodafone for months.


So - settings - apps - phone services - notifications - wi fi calling set to gentle notifications (I don't mind the banner) and go up  level and back down, separately set reminders to silent.


Huawei P30 (not pro), Android 10, unlocked and not sourced from Vodafone.  No vodafone app.


Signal is very patchy here, one side of the house I sometimes get '2 blobs' otherwise one or none.  We are in a cluster of 4 houses in a dead spot with full 4g only 25 yards away, and no network is going to invest in sorting that out. What I get seems to be enough to let SMS work, vital now that banks etc. use 2 step verification.  According to Voda, SMS over wifi won't work on my phone and certainly wont work on my wife's, nor does wi fi calling,  so we are likely to move elsewhere  now the sure signal is dead/withdrawn.  EE seem to be well ahead of the game with  functional wi fi calling and sms over wifi.


Thanks again for prompting me to look at reminders instead of notifications.  Who would have thought...:)



View more options
2: Seeker

Other than changing networks... Has anyone found a workaround or a way of disabling these notifications? Vodafone says they're aware of the problem but don't believe it to be a widespread one. The best response I've had is by raising this issue via Vodafone's Twitter - if they see enough people with the same problem, maybe they'll do something about it.

View more options
2: Seeker

I have had this problem develop on my Samsung S10, very recently. I have used the app to turn off wifi calling but I would rather have the wifi calling on but without the interminable 'messaging on wifi' message and icon. My menus don't look like the ones posted over the last few years.

View more options
3: Seeker

Thank you a thousand times - 'gentle notifications' - it works!

Cannot find post you cited so Ill thank you instead!!


P.S For Mate 20 pro users - the location is settings - apps - phone services - app info - notifications.

View more options
4: Newbie

Continuous notifications means it's switching between 4G and WiFi calling. This is probably because you are in a low cell signal area, thus the reason you want WiFi calling in the first place!


What you need to do is set your preferred network to WiFi instead of Cellular. This setting will also fix other WiFi calling issues such as dropped calls / calls to voice mail. 


The only problem is this is a hidden option. On Samsung, you download a piece of software called "Samsung Band Selection". I'm not sure why all UK network operators hide this option. You could try downloading it on your Huawei. Ignore all the band selection screens and just use it to access the preferred network option. You only need to set it once.

View more options