Showing results for 
Search instead for 
Did you mean: 






Frequent "Can't Find Site" Notifications

4: Newbie

Just migrated my FTTP BB & phone from BT 5 days ago, all set up and working.

However, I am experiencing frequent and seemingly random duration periods where most web sites will not connect and display "can't find site notifications".
To be clear, the hub never drops internet connection as such, LED's on hub and ONT remain normal.

Main browsers are Firefox and Google Chrome running on Windows 10 Pro desktop PC.
Was suspicious of PiHole which is now disabled, never had any issues previously, nothing changed.
Also disabled my browser ad blocker just in case, again, never had any previous issues with this.

So, is this likely to be a fault or is this just a Vodafone network feature?
It's certainly not a one of, has been happening randomly and usually for a short duration practically every day to date.


16: Advanced member
16: Advanced member

Definately not a "network feature", so yes. a fault somewhere along the line. Does sound DNS related.

I think I would try disabling the IPv6, as Vodafone's implementation seems to be causing problems at the moment. 


@JayachMany thanks for the response, much appreciated.
IPv6 is already disabled on Local Network and Wi-Fi 2, must be by default as I never actively did so.

Oh dear, does this mean I will have to negotiate Vodafone support, not looking forward to that!
Just when I was doing so well too finally configuring all my local network devices😒

16: Advanced member
16: Advanced member

I'm surprised IPv6 was already disabled.

Good luck with Vodafone support for a problem like that. Are you sure there can't be another DHCP server on your network. (I know you said you've stopped using Pi-hole)

@JayachTo disable PiHole I have just returned the IPv4 DNS server configuration back to the default Windows configuration "obtain DNS server address automatically" which now ignores the PiHole server, have only ever configured PiHole by that method on my main desktop PC never on the router.

Have never had occasion to contact VF support to date (only on line 4 days), by reputation not looking forward to that experience at all☹️

16: Advanced member
16: Advanced member

@tiffy I run PiHole too. 

In the router set the 1st DNS to the PiHole address and the 2nd to either or

Telling Windows to find DNS automatically will now go to PiHole first and the other address second.

In PiHole pick whatever DNS provider you like but not the router address.

@CynricMany thanks for the response.
My understanding of PiHole operation which I wanted to be only active on my main desktop Win 10 PC was to set the PiHole server IP address in Windows, this worked on my previous BT FTTP installation without any issues?
In PiHole, upstream DNS server was set to "Custom 1 (IPv4)

At this point in time however I want to keep PiHole completely disabled and out of the equasion until/if I get the current investigated/resolved.

Well, my first encounter with Vodafone support, on their chat line which eventually went to a human was to expectation, op was convinced it was a Wi-Fi issue even though my desktop Win 10 PC is directly ethernet connected to the Hub?

After going around in circles for half an hour I respectfully requested that the issue was escalated to 2nd level tech support, surprisingly he agreed right away, probably glad to see the back of me!
Supposed to be contacted by phone within 48 hrs, will have to wait and see if that actually happens.

16: Advanced member
16: Advanced member

@tiffy I hadn't heard of using PiHole for just one computer before. I think you'll have to look at the logs of both the Pi and the router, and also tell Windows to delete and re-establish the ethernet port via Control Panel. I can't help but think that when Windows asks for the DNS server it's getting confused with two answers. You did statically set the DNS in Windows?

Do ensure that IPv6 is off as @Jayach mentioned earlier.

@CynricWhen I set up PiHole over 2 years ago I just followed the on line guide which gave this method of implementation and suited my requirements, ie, applied to my main use desktop PC only, this worked without any issues on my previous BT SH-2 FTTP connection.

As per the method used, Windows Ethernet Network IPv4 "Obtain DNS server address automatically" default setting was deselected, "Use the following DNS server addresses" was selected and the static IP address of my RPi-3B PiHole server entered.
So to answer your question, Windows DNS is currently set to it's default "Auto" to completely remove PiHole from the equasion.
The Hub also remains at it's default DNS configuration "Auto" setting, have never changed this.

I hear what you are saying, I do believe that it is a DNS issue but why does this work most of the time and only intermittently causing loss of internet resolution where the Hub never actually looses internet connection?
With Windows DNS selection set at default "Auto" I'am convinced that PiHole is no longer involved so can be ruled out as a possible cause.
Is there any reason that the Hub DNS selection should not be set to default "Auto".
If the Windows/Hub DNS setup permutations were set up incorrectly surely this would result in internet site resolution not being possible all of the time.

For reference, this is the guide I used to set up PiHole on my system: