Showing results for 
Search instead for 
Did you mean: 






Internet light flashing red despite being plugged in

2: Seeker
2: Seeker

Ive just been going about my night, when my internet randomly shuts off. I thought nothing of it so I just waited about half an hour while i went about doing chores, came to use the wifi, still not working. no matter what i do.

Ive tried all of the solutions - hard resetting, unplugging the power source, unplugging the internet cable from the router, unplugging the plug and moving it to another, and none of them have worked. All other lights on the router are white as normal, including wifi and power, but its just the internet thats not working and i cant understand why. Whenever i try to use it, the wifi tells me that "action is needed" and then it relocates me to the "No internet connection"  page when i click connect and tells me to plug in the internet cable, even though it literally is and has been plugged into the router (screenshots down below)

I currently can't contact customer service since its too late and am stuck using mobile data. I need help on what to do! is this a power issue or an issue with vodafone itself?

medium.jpg2024-04-16 (1).png2024-04-16.png




16: Advanced member
16: Advanced member

Your images will take a while to be moderated, and hopefully by the time they are, your internet will be back.

Assuming you are on FTTC, not FTTP, flashing red internet led means the router is not connecting to your cabinet, so check the security of the DSL cable at both the router and BT socket ends.

If that all looks O.K. it's likely a problem with the Openreach cable going back to the cabinet.