Showing results for 
Search instead for 
Did you mean: 






TP-link access points not working Since swapping to Vodafone today

2: Seeker
2: Seeker

I've got 3x TP-Link AP EAP-225v2
All working ok with Sky Full Fibre broadband

Yesterday we swapped to Vodafone (new router), plugged everything in and im having issues with the WiFi , keeps coming up with "incorrect password for AP "
Ive defaulted the AP and works ok with no security
As soon as i change the security mode to WPA-PSK as previous used i get incorrect password message when i try to log into the WiFi with my mobile , laptop just wont connect
Think the Hive is playing up also but im trying to sort out the AP's first
I've disabled the Vodafone WiFi but that didnt help

All our TV's , mobiles, tablets run off the WiFi apart from my PC , so really need to sort this out soon or go back to Sky



16: Advanced member
16: Advanced member

If you're not using the Vodafone routers Wi-Fi, and are just trying to connect to the AP's then whoever is suppling the broadband is irrelevant. In fact when you swapped from Sky there should have been no need to do anything at all except move the AP connection from the Sky router to the Vodafone one.

Unless I'm misunderstanding something.

Thats exactly what i have done , removed the Sky router and installed the vodafone one , but now I cant access the existing AP Wifi unless the AP has the security set to none which is obviously not really an option.

I guess there's some setting or they just aren't compatible

16: Advanced member
16: Advanced member

@nyckuk wrote:
I guess there's some setting or they just aren't compatible

No, they must be compatible with any router.

Have you given the AP's their own SSID?

Yes they all have the same SSID ... I used the same setup on Virgin originally , then moved to SKY and they worked fine , but not working on this new Vodafone router 

16: Advanced member
16: Advanced member

If these are working as extenders, you'll need to reset them up again from scratch as while they have their own SSID, they also need to connect to the router - if the router SSID has changed they'll no longer be able to talk to it!
Provided they are compatible!!!  WPA-PSK is quite old, you should really be looking at WPA2-AES.  I'm sure @Jayach can tell us if the VF router can manage the older authentication format!
*While WPA-PSK is insecure it's a wireless authentication protocol, so it's not the end of the world if you do have to use it - ie don't break out the tin-foil hats!

They not extenders i.e: extending the Vodafone router Wifi , The Wifi is turned off on the Vodafone router so basically using it as a modem and using the AP's as it own Wifi network   . As i mentioned this worked on my previous Virgin and Skys routers  

16: Advanced member
16: Advanced member

I'm assuming @nyckuk has one of the AP's hard wired to the router, they can't be extenders as they say they disabled the Vodafone routers Wi-Fi.

Yes WPA is available on the THG3000, 


although why they would use that as the EAP-225v2 can use WPA2, perhaps they have some really old devices.


@nyckuk Just how are you connecting the EAP-225v2's to the Vodafone router?

They are connected via a D-Link DGS-1008p 4x POE 4xnormal ports that does the power over ethernet  for the AP and the normal ports to Xbox,PS5 . I cant see your photos you've posted