Showing results for 
Search instead for 
Did you mean: 






5G Gigacube MTU issue and UPNP issues on XBOX

2: Seeker
2: Seeker

Hi all,

I have the TCL HH500V 5G GIGACUBE with the GigaCube data plan unlimited, due to where I live its kinda the best option I had as I cant get a fixed broadband line better than about 5mbps. Upload and download speed wise its pretty good and often get over 100mbps down and 17mbps up HOWEVER ever since I've had this my connection to online multiplayer games tends to be 'fragile' and for the past few weeks it has been downright appalling often completely unable to connect or stay connected to online games through my PC or XBOX 

When checking through XBOX the diagnostics say that I have MTU problems and my UPNP is not available - this could have been going on since day 1, ive always had a bit of latency or packet loss with games but the recent weeks issues have driven me over the edge with it as it completely stops me playing online games

I have tried the following:

Reset hub, change Ethernet, connect via WiFi, port forwarding the xbox ports used, turning on UPNP on the router settings (tried these individually and simultaneously) switching to 4G only, trying both the 2.4ghz and 5ghz connections and NOTHING works.

My MTU seems stuck at 1360 on my xbox, being told it needs to be at least 1384 by Microsoft support, and still receiving UPNP not available errors so im completely out of options

I have tried to phone the support team who tell me "MTU is not something they are aware of or trained on" and that they would phone me back soon, but its been 2 hours now since they ended the call and nothing so im not optimistic for a call back at this stage

Is anyone aware of this issue and have any ways to fix this? or will I have to look at other options elsewhere and potentially to end my service early?