main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Internet speed

Slow speeds from Vodafone Gigacube 5G in Central London...

Highlighted
2: Seeker

I recently purchased the unlimited plan for the Gigacube and upgraded from my 12mbps down/1mbps up DSL connection. 5G is not available in my area yet (Clapham Junction) but will be soon. I set it up, updating the firmware, slotting in the SIM and placing it near my top floor window (positioning doesn't matter). Speeds would fluctuate depending on peak usage because it's 4G but I was clocking in at 70-80mbps download and 30mbps upload. However, at least once a week or possibly more the speeds will drop to and average around 6mbps down/15mbps up across all my devices such as my ethernetted desktop and smartphone. The timing of these drops varies as it's never a set time during the week/day but appears to be occurring randomly.

 

I've contacted Vodafone, who offer my unlimited data plan contract for the Gigacube (Huawei 5G CPE Pro) but their support has been useless. Their suggestions...

 

1.) Engineering work ongoing. Possible but unlikely, seeing as this continues for ages unless fixed. My smartphone is also with Vodafone and that's clocking in at a good speed.

2.) Network logs need updating. Not sure about this but I keep the Gigacube updated and it does so automatically anyway.

3.) Remove the SIM and place it back after x amount of time. This worked on 2 separate occasions but has failed entirely for the past 24 hours.

4.) I'm not on the correct plan. This was a straight lie as I'm paying £50 a month for unlimited data as stated in my contract. No limitations. Period. Bear in mind, only 1 support guy replied with this.

 

I honestly have no idea what is causing this. I doubt it's an actual issue with the Huawei 5G CPE Pro router as I haven't damaged it in anyway or form and I don't see why it would be an issue with that. I purchased the Gigacube and contract nearly a month ago and have since used 900GB of bandwidth. I've browsed online for solutions but there is very little support on the 5G Gigacube. I should also ensure the SIM is correctly placed in the router but I'm pretty sure it is. I personally believe this stems from either Vodafone throttling or the supposed "engineering". Any thoughts or suggestions would be graciously appreciated.

View more options
3 REPLIES 3
Moderator

I'd like to get to the bottom of this for you @Janupedia so I'll need to ask a few questions. 

Are you able to test your GigaCube's speeds in another location, such as a friend or a relative's home to see if the speeds fluctuate there too?

When testing your SIM in another device, do you have the same experience?

Please also let me know the postcode of the area and I can check to see if we're aware of any current issues. If you'd prefer not to share this on the thread, it can be added to your profile for our team's eyes only. 

 

View more options
2: Seeker

I had no problems when on my 30Gb contract. I recently upgraded to Unlimited MAX and upload speeds are now awful all over Essex and London.. Having confirmed I am on the Max (unrestricted) contract the local Vodafone shop told me the problem was my 5C I-Phone. So, just spent £1,000 on a top of the range I-Phone XS Max. Still no better than 5Mbps upload. Is Vodafone throttling speeds? 

View more options
2: Seeker

Honestly, I tried everything but there's barely anything on this Huawei 5G CPE router anyway. EE (overpriced and not in stock) and Three (better 5G network/unlimited plans) also offer the same router but with different plans. I sent mine to the repair shop and have been waiting for 3 weeks. I've decided just to move to Three. 

View more options