cancel
Showing results for 
Search instead for 
Did you mean: 
1

Ask

2

Reply

3

Solution

Honeywell Evohome cannot get Weather info over Vodafone (Blocked address or port?)

jweaver
2: Seeker
2: Seeker

I have an Honeywell Evohome central heating controller, which has a feature where it polls "Weather.com" to get the latest weather (Specifically temperature) and then brings the heating on earlier/later if needed.

Problem is, it doesn't work, atleast not for me..... I tried everything and then stumbled upon another user who also had the same issue and the thing we have in common is Vodafone broadband.

I tried everything and was able to prove the fault was with my connection as when I connect to my neighbours broadband (BT), or my mobile Hotspot (EE) it works first time... But as soon as I go back to my home broadband, it just stops working.

To rule out something on my router, I have put the Evohomes IP into the DMZ and I get the same issue..

I am lead to believe that the Evohome polls this address to get the weather

http://104.209.185.251/WeatherAPIProd/api/weather/current?appKey=b9db7a3d469892e8&language=en-us&loc...

And this appears to work.. But interestingly, I see this in my router periodically:

22.02.2023 23:58:30 lan Info process_request: trans IP GET http://192.131.167.190:49153/Weather...onKey=50104_PC for 7
22.02.2023 23:58:30 lan Info Request (file descriptor 7): GET /WeatherAPIProd/api/weather/forecasts/hourly/15hour?appKey=b9db7a3d469892e8&language=en-us&locationKey=50104_PC HTTP/1.0
22.02.2023 23:58:00 lan Info process_request: trans IP GET http://192.131.167.190:49153/Weather...onKey=50104_PC for 7
22.02.2023 23:58:00 lan Info Request (file descriptor 7): GET /WeatherAPIProd/api/weather/current?appKey=b9db7a3d469892e8&language=en-us&locationKey=50104_PC HTTP/1.0
22.02.2023 23:57:53 lan Info Probing device 20:28:bc:1f:c0:ca IP address 192.168.1.234 on interface br-lan

I have tried to engage Honeywell, but their stance is "it works for us", so I am not sure how I can go about debugging this, let alone fixing it.

Does anyone have any thoughts?

 

3 REPLIES 3

jweaver
2: Seeker
2: Seeker

oh yes.. One thing I forgot to mention.. Out of the blue in the summer I noticed that this was fixed.. (You can tell because the temperature appears on the home screen)...

Nothing changed at my end.. It just started working out of the blue.. I just assumed that perhaps VF had done some kind of upgrade, or perhaps had reviewed their "blacklists".

But a few weeks later, it disappeared again and never came back.. I can't explain this, but it was definitely working for around a month out of the blue.

Nice find.. I never imagined anyone else would be seeing this as the Evohome is a bit of a niche product

I don't fancy factory resetting the router and having to set everything up again just to get the temperature shown.. Especially as it fixed itself for a month and then failed again, so its obviously a bit flaky.

I might reach out to the original author of that thread and see what his experience has been since.

But if I know its something on the router, I can start poking around now to see if I can make a change which might kick this into life.

Thanks for pointing me in this direction.