Showing results for 
Search instead for 
Did you mean: 






Erratic speed and pings with Gigacube 5G

2: Seeker
2: Seeker


First of all, apologies for the wall of text!

I have been having trouble with really erratic broadband speeds on all devices for the last couple of weeks. I've tried to get help from Vodafone through Live Chat but, after 90 minutes of being passed from person to person with no real attempt being made to fix the problem, I gave up.

Up until a couple of weeks ago my speeds were pretty consistently around 25-30mbps at all times of the day. Not hugely impressive speeds but not bad considering I'm in a very rural area and a fair distance away from my nearest Vodafone mast.  The Gigacube has been in place since October last year and has given a really reliable connection up until now. It is connected to the 4G network (no 5G in this area) through an external antenna (Poynting XPOL-1 V2 5G) mounted just below the soffits on the side of the house facing the direction of the nearest mast. This antenna has been in place since October and has given me no issues. I have recently tested the Gigacube without the antenna connected and I have the same speed issues.  With the antenna connected I have 4 out of 5 bars on signal strength, without the antenna I have 2 or 3 bars.

I have 3 x TP-Link Deco M5 access points providing Wi-Fi in the house - the Gigacube's Wi-Fi is turned off and the main Deco is connected to the Gigacube via an Ethernet cable. Again this is not a new set-up and has been running for months without any issues. I have checked the Status Checker repeatedly but I haven't seen any reported issues.

The problems are happening on all devices, both wired and wireless. The slow speeds manifest mainly as problems in streaming any kind of video content (YouTube, iPlayer, Zoom, Teams etc) as this is what we mostly use the internet for. My wife works from home and is finding it very difficult to conduct her meetings etc.

I have made no changes to our set-up here, the only correlation I can think of is that I recently contacted Vodafone to have the adult content bar lifted from my account. The problems seemed to start at around the same time but I can't see how the bar being lifted could have caused this problem.

I've attached a screengrab of some Speedtest results.

If anyone can suggest a reason for these issues or any way I can get them sorted I'd be really grateful :Smiling:




Community Manager
Community Manager

Hey @J1mmycee, I'm sure we can stop these issues for you. To start with, take a look at our awesome GigaCube troubleshooting guide and let us know how you get on. If the steps don't resolve your issues, please complete the attached template and we'll take a closer look into this for you.

Hi Mark,

Thanks for your reply, there doesn't seem to be a template attached to your message though?

I have run through the troubleshooting guide, there hasn't been any change or resolution to the issue. I have tried disconnecting all devices bar one and there has been no difference.

If you could send me the template I will fill it out and get it back to you ASAP.

Not applicable

I've popped the template below @J1mmycee. If you'd prefer not you put your postcode in the thread, you can pop this in your account and we'll be able to find it there.

1) Does the issue happen in just one location? If so, how far do you have to travel to regain service?

2) Does the issue occur if you try your SIM card in a different phone?

3) What errors are seen or heard when the issue occurs?

4) Does this happen on 2G, 3G, 4G or all?

5) When did you first notice this issue?

6) Is the issue permanent or intermittent? If intermittent, are there certain times of the day when it occurs?

2: Seeker
2: Seeker



I am really interested in finding out more about your home setup. I too live in a rural area and I the gigacube installed 1st Feb but the connection is shaky, I can't get past speeds of 2 - 5 despite Vodafone showing full coverage and the light is steady green on 4G ( No 5G either) . would you mind talking more about your antenna and boosters. I 'm trying to see if I would be able to boost my connection to assist with my remote desktop?