Showing results forΒ 
Search instead forΒ 
Did you mean:Β 






Weird Twitter issue whilst using Vodafone 4g Date Sim

2: Seeker
2: Seeker

Morning all,

Bit of a weird issue here, which I'm hoping to get a bit of advice about.

I have a Vodafone 4g data sim, installed in a TP-Link Archer MR600 router. Connection is great, and I'm very pleased with the service, but over the last 2-3 days I have found I am unable to load Twitter media of any kind on an iPad or iPhone over my wifi without using a VPN, still routing in UK . Research (well ok, Google) suggested it might be a DNS issue, but what is really confusing is that the same wifi connection works absolutely fine on a Windows machine.

App deleted, cache emptied, latest iOS update applied, latest app reinstalled, same issue. Personally I don't believe this is a Vodafone issue, but trying all avenues, so Apple, TP-Link and Twitter support will also be getting asked πŸ™‚ Just trying to work my way through it.



Actually, tried that workaround and it initially didn't change anything, then when I removed the APN from the router it started working.  I suspect that has flushed the DNS and fixed things?

I tried flushing the DNS on the APN (by changing the DNS) but it made no difference.


This issue (I'm almost certain) lies deeper in the Vodafone and network infrastructure stack than people's modem and APN/DNS settings....

It made no difference to me.

I have exactly the same issue. 


Connect to vpn its gone. Vodafone 4g sim or gigacube both have the issue.


Please fix

3: Seeker
3: Seeker

Im still getting Twitter media not loading or displaying for 4 days now. Mobile phone not showing and work mobile (which I tether to for work) both not displaying. PC when tethered same output.

Connect to BT WiFi and all is good (shame my BT WiFi is so poor). Can Vodafone not shed some light or help here?

I also have this. Mobile on Tesco network works fine. Same mobile on wifi based on Vodafone mobile broadband doesn't work with Twitter. Different mobile with different Vodafone SIM can't do Twitter on mobile data either. Computer (linux/chromium) doesn't Twitter on wifi. These things only happen with twitter - images don't get loaded. When I hard refreshed twitter on Chromium, it wouldn't load at all. Before I was completely locked out of twitter on the computer, if I clicked on a picture to load it in a new tab, the progress bar would always stop in the same place.

So maybe Vodafone is limiting the amount of data for each http request from Twitter - it seems there may be dns failures too for ton.[somthing] - this may not be relevant. Is this some kind of load management?

PS I am based at the bottom of Longdendale in High Peak

2: Seeker
2: Seeker

I am also having this issue on my Vodafone gigacube. I am not having this issue on my Three 5G router. It seems to me either there is a fault on the Vodafone network or there is a Vodafone policy.

Does anyone else have any further information?

3: Seeker
3: Seeker

Same here. Tethered laptop won't load Twitter, nor will Safari on my phone. App loads, but does not display images/video. All fine on Wifi, all other mobile data seems fine. Contacted Vodafone via chat and they removed age restriction from my account which seemed to solve the issue for an hour or so Saturday night, but now not working again....

Further to this, discovered from [Removed] that Twitter on Firefox does work. So somehow the problem seems to be the combination of Twitter, Vodafone; and Chrome/Chromium and derived browsers or apps


[MOD EDIT: This post has been edited to remove off personal information please see Community Guidelines]