Showing results for 
Search instead for 
Did you mean: 






New Vodafone Broadband app

3: Seeker
3: Seeker


I recently updated the Broadband app from the Apple store and now I am unable to log into the app without the error message saying "Something unexpected error has happened".

My understanding from emails about the updated app is that I have to enter the login details that I would use for logging into My Vodafone.

Just wondering if anyone else is having the same issue as I have tried calling support and web chat but they are being vague saying it might be a glitch in the app and it might sort itself out.





They told me they will now deleted the whole of my account so I can registered it again… have a eta of 24-48 hours so I’m waiting at the moment… will update if it works

Hi Titaniummom

No, it still the same.

I tried the social media chat via FB messenger but you messaging in and different people are replying to you.

So far I have been told to delete my app reinstall it.

I was told to press the Wifi button on the router (asked if that that was right because before it was always the wps buton) definately the wifi button so I went with it and again no luck still get the same eror message.

I was asked to 

Reboot the router

Reset the router

they reset my password for my Vodafone account so many times I was emailed a temporary pw I was told to log into the app with that and follow the instructions.

I logged into the broadband app with the temp password and a message appeared telling me to change my password by clicking the forgot password link below which I did and that just sent me to a page to put my username in which sent me another temp password so I was going around in circles.

I told them its not working and that the only way I can change my password from a temp one is through my vodafone.

I was told that I should be typing my username in capital letters which made no difference.

I was then talking to a supervisor who confirmed it should be the wps button and not the wifi button but I was trying both anyway  but still no access.

Then I was told just to try accessing the app in a few days the server might be down.





yes.. been through that all since March… they have no clue and now made it worse for even more ppl than just the Alexa population.

i want back on my complaint, talking to so called experts on chat is infuriating. I’d recommend raising a complaint via the Vodafone portal… the more ppl they see has an issue it may finally prompt to make then spend to fix it… unlike they did just ignore me for past 10 months. 

3: Seeker
3: Seeker

Registering again did not work.. 

2: Seeker
2: Seeker

I am also having same issue for a long time since they have updated the app. I am also chasing Vodafone to resolve this issue but seem like they are not bothered. As i am not able to connect boosters with the main hub and also not able to change my router password. I am really ##~## off now by this new update.