Showing results for 
Search instead for 
Did you mean: 






Robert's Colourstream internet radio blocked

2: Seeker
2: Seeker

I'm trying to assist my parents in getting the above device working. It worked patchily until recently, and now I just get either Network error or network timeout.


I've changed the DNS handed out by vodafone's router to be and, just in case whatever sites it accesses are blacklisted.


I don't know which sites this device it trying to connect to, but it is being blocked. For now, this is working via a mobile hotspot instead.


16: Advanced member
16: Advanced member


Is the ethernet plugged-in at the same time as you try to connect WiFi?

What WiFi signal strength is showing on the front panel?

Only 802.11b  (2.4GHz), 802.11g (2.4GHz) and 802.11n (mixed mode 2.4/5GHz) are supported. Have you tried with the 5GHz WiFi tuned off, if the router allows that?

Does the router think that it is connected?

Is it the BBC that is the problem or all radio stations?



Ethernet wasn't plugged in, but I did try a ethernet connection, bypassing wifi, and that also has errors. My thinking is it's some kind of upstream filtering (ie within vodafone)

16: Advanced member
16: Advanced member

@milkydood wrote:

My thinking is it's some kind of upstream filtering (ie within vodafone)

I very much doubt it, as long as you are not using Vodafone's DNS. (which you say you are not)

OK, what then? Given I can take this device and plug it into my LAN and it works just fine, I suppose it's possible whatever sites it needs to contact are blocking vodafone's IP addresses, but seems even higher in the unlikely stakes

16: Advanced member
16: Advanced member

If it works when plugged into the LAN then it's not blocking. It may be possible that the router is on channel 12 or 13 of the 2.4GHz band and the radio cannot use those two channels.

Have you got a WiFi analyser app on your phone or laptop that would confirm the channel number?

Sorry, I'm being unclear. It works when I bring it to my house and plug it into my router's lan ports (not vodafone as an ISP).


It doesn't work at my parents house when I plug it into their router's LAN ports (vodafone)

I think what I really need to do is compare tcpdumps and see what's going on.

16: Advanced member
16: Advanced member

Open a browser and check that you can open , which I see now redirects to Nuvola who list some Roberts devices but not the Colourstream. I have no idea (a) when this changed, and (b) if the URL is needed to get the radio to function properly.

According to the URL is not blocked by VF.

16: Advanced member
16: Advanced member

I'm wondering if setting up a guest wifi and connecting the radio to that would fix this. Worth a try as while this is the first time I've come across this particular problem moving the device away from the main network seems to fix problems for a growing list of devices.