main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Other broadband queries

Square router network is suddenly invisible to some devices

SOLVED
View solved solution
CrossChannel
3: Seeker

Last month, some - but not all - of my devices suddenly stopped being able to see my network on our square THG3000 router. They don't list my SSID network name as a choice for joining, but their Wi-Fi seems to be working perfectly as they can all still recognise my neighbours' networks, or join a mobile hotspot, etc.

 

This is intermittent: on some days all is fine and every device in the house can see my network. But on others, the same few devices can't see our network. This changes without me doing anything (for example, I haven't restarted, reset, re-programmed, and so on). Today, the devices can't detect the network.

 

If I plug in an older Vodafone router (an HHG2500 set to the same SSID and password) all my devices can see and join the network consistently, every day.

 

I see that it's no longer possible to change channel numbers via the app or router UI (as detailed here https://forum.vodafone.co.uk/t5/Other-broadband-queries/Wireless-channel-selection-missing-in-expert...), but I suspect that this is possibly something to do with the issue. I've spoken to Vodafone's tech team and received some confusing advice which hasn't fixed the problem.

 

Any ideas? I'd really like to use the THG3000 as its coverage seems better than the older HHG2500.

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
CrossChannel
3: Seeker

Thanks so much. I've solved the problem now.

The three replies in this forum gave me more of an idea of what to do than the ten (this isn't an exaggeration, I checked) members of Vodafone's Tech Team support I corresponded with.

The problem was indeed to do with WiFi channels - specifically that in the US they use only the first 11 channels in the 2.4GHz band whereas we use an additional two (12 & 13) in the UK. Any WiFi kit which isn't properly set up will likely default to only using channels 1-11, to be safe.

The THG3000 router is now automatically managed to aim to optimise available bandwidth and the user cannot override this. Without any warning, it had stopped transmitting on a channel between 1 and 11 and switched to channel 12. This explains why only some of my devices, which weren't set to receive on all the UK channels, couldn't see the network when others were fine. It also explains why reverting to the older router fixed things - it's always transmitted on channel 1 and is presumably too old for Vodafone to manage automatically.

What could have been done better is for any one Vodafone's Tech Team to spot this - not one asked me to check the channel numbers. Surely this is a likely outcome of automated channel switching?

I fixed this on Windows via Settings > Network & Internet > Change adapter options > [right-click on your WiFi adapter] > Properties... > Configure... > Advanced > [then the available settings differ between adapters]

On Raspberry Pi the setting is in Localisation > WiFi Country which is available in Raspberry Pi Configuration via the Desktop Menu or by typing "sudo raspi-config" (without the quotes) in Terminal.

Thanks again!!

View solution in original position

View more options
12 REPLIES 12
Cynric
12: Established

Could you monitor the channel numbers in use? There are posts from people saying that the THG3000 changes channels by itself.

View more options
CrossChannel
3: Seeker

No, channel numbers are no longer available, either in the Android app or in the latest router firmware UI.

Could it be that the channels are regularly changing automatically, to exclude some WiFi cards?

View more options
Cynric
12: Established

Something like that. If you get a channel analyser app for your mobile you may see changes. Not knowing whether your devices can automatically follow the channel change I can't precisely comment.

View more options
Jayach
16: Advanced member

@CrossChannel wrote:

No, channel numbers are no longer available, either in the Android app or in the latest router firmware UI.


Whilst you can no longer change the channel, you can see what channel it is using on the Status & Support tab.

Main Wi-Fi 2.4 GHz

Status
On
Name
vodafone04035D
MAC Address
d4:35:1d:04:03:xx
Security
WPA2-PSK
Channel
4
Bandwidth
72 Mbps
Max BW
288 Mbps
Minimum Sync Speed
72 Mbps

Main Wi-Fi 5 GHz

Status
On
Name
vodafone5G04035D
MAC Address
d6:35:1d:04:03:xx
Security
WPA2-PSK
Channel
100
Bandwidth
866 Mbps
Max BW
2 Gbps
Minimum Sync Speed
866 Mbps
View more options
CrossChannel
3: Seeker

Thanks so much. I've solved the problem now.

The three replies in this forum gave me more of an idea of what to do than the ten (this isn't an exaggeration, I checked) members of Vodafone's Tech Team support I corresponded with.

The problem was indeed to do with WiFi channels - specifically that in the US they use only the first 11 channels in the 2.4GHz band whereas we use an additional two (12 & 13) in the UK. Any WiFi kit which isn't properly set up will likely default to only using channels 1-11, to be safe.

The THG3000 router is now automatically managed to aim to optimise available bandwidth and the user cannot override this. Without any warning, it had stopped transmitting on a channel between 1 and 11 and switched to channel 12. This explains why only some of my devices, which weren't set to receive on all the UK channels, couldn't see the network when others were fine. It also explains why reverting to the older router fixed things - it's always transmitted on channel 1 and is presumably too old for Vodafone to manage automatically.

What could have been done better is for any one Vodafone's Tech Team to spot this - not one asked me to check the channel numbers. Surely this is a likely outcome of automated channel switching?

I fixed this on Windows via Settings > Network & Internet > Change adapter options > [right-click on your WiFi adapter] > Properties... > Configure... > Advanced > [then the available settings differ between adapters]

On Raspberry Pi the setting is in Localisation > WiFi Country which is available in Raspberry Pi Configuration via the Desktop Menu or by typing "sudo raspi-config" (without the quotes) in Terminal.

Thanks again!!

View solution in original position

View more options
Nemain_79
3: Seeker

Thank you so much @CrossChannel, I've been messing about with this all day!

 

Please would you be able to tell me what to look for once I get to Advanced?  I'm not sure what to do next

View more options
CrossChannel
3: Seeker

It's difficult to say as each driver is different. You're looking for something which decides what channels the WiFi adapter is listening to. It may say something to do with location or country as this has a bearing on what channels are used, or it could be just numbers. Turn them all on if you can! Sorry I can't be more exact.

View more options
Nemain_79
3: Seeker

Mine seems completely different, did find a potential channel section and change it but no joy.  Ah well, thanks for your reply and your initial post!  I'm definitely further on than I was :Smiling:

View more options
Jayach
16: Advanced member

@Nemain_79

I think you are still trying to change the WiFi channel in the router, give up it can't be done at the moment. (except with an earlier android app)

@CrossChannel is talking about changing the settings on the device so it can see channel 12&13.

First thing is to find out what channel your router is using. See my earlier post here Solved: Re: Square router network is suddenly invisible to... - Community home (vodafone.co.uk)

If it is 12 or 13 then that is your problem. If you say exactly what device is unable to see the router we may be able to say how to change it. Be aware some devices will never be able to see 12 or 13.

View more options
Nemain_79
3: Seeker

Thanks Jayach, probably me not explaining myself properly!  

 

I've given up with trying to change channel - am still attempting to d/l that old app, no luck so far - phone or PC.

 

I checked your post earlier and could see that I'm on Channel 13.

 

I've got a Dell 1397 Mini Card - other people have suggested changing from Antenna to Aux -  Bur can't see an option for that.

Have attempted to  change to Channel 13 under hopefully the right bit.  Still no joy.  I've attached a photo, fingers crossed! :Smiling:

20210211_144348.jpg

 

 

 

 

View more options
Nemain_79
3: Seeker

I was unable to d/l the APK file for the older version of the app - for whatever reason.  Someone else posted this on a different thread and it has worked!  It automatically uninstalled my newer app and installed the older app - and kept details (names of all devices connected etc.) I was able to change the channel.  Hallelujah!  Have posted here in case it's help to any one else..

 

Also, as an earlier post 

https://vodafone-broadband.en.aptoide.com/app

Download & install,  go to wifi, advanced settings, page down to change channel.

You may need to select 2.4 or 5 Ghz on wifi page (mine is split)

Switch updates for the app to off or google will update automatically,  has worked for me for a while.

View more options
Jayach
16: Advanced member

Congratulations on resolving your problem.

I don't think you can change the channel in the wireless card driver, It should pick up it's location from the operating system and be able to use whatever is allowable for that region. If you are using Windows 10 just make sure it is set to UK.

Screenshot 2021-02-11 184054.jpg

Also a different driver may also cure it.

Of course now you have been able to change the channel it's no longer important.

View more options