main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Samsung S20FE wifi calling

ADaG
2: Seeker

I have wifi calling activated and working on my new Samsung S20FE. The problem happens when I leave my house then return. I find my wifi calling is not working even though the phone is connected to the router and wifi calling is still activated in phone settings.  The only way I can solve this is to restart the phone. Any ideas on solution??

View more options
4 REPLIES 4
BandOfBrothers
17: Community Champion

It's possible the phone is struggling to switch from mobile network connection back to Calling Over Wi-Fi or the phone is picking up a faint network connection where you live and won't switch unless network connection fails @ADaG 

Some phone's work better than others with this feature I find.

Current Phone >

Samsung Z Fold³ 5G.

Previous Phone >

Samsung Note 20 Ultra 5G - SM9860.

View more options
ADaG
2: Seeker

Thanks BofB for reply. The iphones in my house don't seem to have this issue so you saying some phones work this feature better has me thinking.

View more options
BandOfBrothers
17: Community Champion

Your very welcome @ADaG 

It's not always the manufacturer but the instead the model of phone.

Some phone's hold onto signal better than others so it could be that your phone works harder at holding onto Network connection  !

I've seen posts here and elsewhere where one phone model seems to work better than another whether it's an iPhone,  Samsung, Oppo or Huawei etc.

Current Phone >

Samsung Z Fold³ 5G.

Previous Phone >

Samsung Note 20 Ultra 5G - SM9860.

View more options
AnnS
17: Community Champion

Hi @ADaG 

 

As you are not going to be using WiFi when you are out the easiest way to solve this would be to turn off WiFi when you leave the house and turn it back on when you return home and the phone will automatically connect to Vodafone WiFi calling.

 

However, if you go into your connection setting and click WiFi, select the three dots at the top you can turn on WiFi automatically when you are in places you use frequently and turn it off elsewhere, your phone will then automatically connect to WiFi when you are home.

 

Understandably, you don't have the same problem with your iphone, but fingers crossed this helps with the problem.

View more options