main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

*** UPDATE *** Galaxy s7 wifi calling ***SOLVED***

SOLVED
View solved solution
Highlighted
4: Newbie

Hi all

Just a quick word about my experience today regarding the wifi calling option on my Galaxy s7.

Earlier today I spoke (via online chat) to a Vodafone "online tech specialist" and asked him how to turn on wifi calling on my device as I could not find any way to do it within the settings of my device. He told me not to worry and that he could indeed help me with this.

After a couple of minutes he said that he had turned on the wifi calling feature and that it would take approximately twenty minutes to become active.

Some time later I logged in to my online Vodafone account and went to "Services and extras > calling options.

Sure enough on scrolling down the page I could see that wifi calling was indeed turned ON!

So I then went in to my device settings again and ....... nothing,  still no way to turn wifi calling on /off and I've searched everywhere believe me, every dark seedy corner within device settings/call settings/wifi settings, but nothing. So back to online live chat and I explained the whole thing to another "Tech" guy who said he would escalate the enquiry and another member of the "Tech team" would be in touch within 24/48 hours.

I must point out that I'm NOT here on a Vodafone bashing mission, I just want what has been promised and thought that some other s7 users might be interested in this. Maybe I'm just not seeing something that's right there in front of me???

I will update this post when/if anything changes

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
4: Newbie

OK here's the update as promied... I recieved a text message from Vodafone today which said

"We have been working on your wifi calling issue, please could you re-test this option by placing the handset into flight mode then connect to your wifi to see if the service goes live. If your issue persists please contact us on .... "

So i followed the instructions and switched on flight mode, connected to my wifi and unfortunately there was still no option anywhere within my phone settings to turn wifi calling on/off.

However I did try to make a call but all I got was a pop up box that read "flight mode on, turn off flight mode to make calls"

so as instructed I dialled the number they gave me and I got a Vodafone tech guy called Adam. I explained the situation and he said "not to worry sir I will have the wifi calling feature working very soon, please hang up the call and I will call you back in twenty minutes"

After a couple of minutes I thought I'd just have a quick look at Call Settings, not expecting anything to have changed and still expecting there to be no wifi calling on/off toggle ..... WOW.... how wrong I was! as if by magic there it was! I just scrolled to the bottom of settings (a dark gloomy place i'd visited hundreds of times before without success) and THERE IT WAS!!  ..... WIFI Calling on/off.

I quickly put the phone in to flight mode and BINGO I made my first beautiuflly crystal clear wifi call!

Adam called me back as promised and that was that. I do have to say at this point that if i have ever encountered any kind of problem with Vodafone be it a tech issue or a billing issue the problem has ALWAYS been dealt with swiftly and professionally. So thank you Vodafone

 

 

 

View more options
7 REPLIES
Moderator

Please keep us updated with this @ilsonlad1.

We'll be happy to help should you need us.

View more options
4: Newbie

OK here's the update as promied... I recieved a text message from Vodafone today which said

"We have been working on your wifi calling issue, please could you re-test this option by placing the handset into flight mode then connect to your wifi to see if the service goes live. If your issue persists please contact us on .... "

So i followed the instructions and switched on flight mode, connected to my wifi and unfortunately there was still no option anywhere within my phone settings to turn wifi calling on/off.

However I did try to make a call but all I got was a pop up box that read "flight mode on, turn off flight mode to make calls"

so as instructed I dialled the number they gave me and I got a Vodafone tech guy called Adam. I explained the situation and he said "not to worry sir I will have the wifi calling feature working very soon, please hang up the call and I will call you back in twenty minutes"

After a couple of minutes I thought I'd just have a quick look at Call Settings, not expecting anything to have changed and still expecting there to be no wifi calling on/off toggle ..... WOW.... how wrong I was! as if by magic there it was! I just scrolled to the bottom of settings (a dark gloomy place i'd visited hundreds of times before without success) and THERE IT WAS!!  ..... WIFI Calling on/off.

I quickly put the phone in to flight mode and BINGO I made my first beautiuflly crystal clear wifi call!

Adam called me back as promised and that was that. I do have to say at this point that if i have ever encountered any kind of problem with Vodafone be it a tech issue or a billing issue the problem has ALWAYS been dealt with swiftly and professionally. So thank you Vodafone

 

 

 

View more options
Moderator

That's great to hear you're now able to use Wi-Fi Calling @ilsonlad1 :smileyvery-happy:

Thanks for keeping us updated on the outcome of this. If there's anything we can help with in the future, please don't hesitate to let us know and we'll be happy to help.

View more options
4: Newbie

Great to see you got yours working  but can I ask what version of android your running. I had is working on my S7 on Android 6 but when I updated to Android 7 the option for wifi calling dissappeared and never had any luck getting it back!!.

 

 

View more options
Moderator

@jcowan69 So we can look into this for you, I've sent you a private message with details on how to get in touch.

We'll be able to access your account and get your issue resolved 😊

 

View more options
3: Seeker

I have also tried everything to get Wi-fi calling working on my 7 edge but no luck. Any help would be appreciated

View more options
Moderator

@dclclarke I'm sorry to hear you're having problems with this. We have an online step by step guide on how to set up Wi-Fi Calling. Please be aware, to be eligible for this, you need to have one of the following: 
- A Pay monthly, Red Extra or Red Entertainment plan
- A Red or Red Value Bundle
If the issue persists, please pop back to us on here and we'll take a closer look 😊

View more options