main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

wi-fi calling: continuous notifications it's available - how to stop it?

4: Newbie

@Mark -- OK, thanks, I'll give it a shot and report back.

I was hoping to avoid that but... Oh well.

View more options
4: Newbie

@Mark

Problem "solved". The phone is no longer likely to notify me about Wi-Fi calling being enabled because Wi-Fi calling is no longer an option.

Thanks a million.

View more options
4: Newbie

Still no news...

BTW I went and had a look at other forums for myself, in particular the Huawei forum. Huawei are indeed recommending that users perform a factory reset, but users are NOT reporting back that it helped. They're reporting that it removed Wi-Fi calling from the phone altogether, as it did for me. In response to that, Huawei are reminding people that Wi-Fi calling is an operator added feature and pointing users back at Vodafone (this doesn't happen with other operators' firmware).

https://uk.community.huawei.com/software-40/p20-pro-keeps-notifying-me-of-wifi-calling-1735#post1328...

So I'm looking in your direction again. Is Vodafone going to fix this with a firmware update any time soon?

View more options
Moderator
Moderator

Thanks for getting back in touch @grsbanks. When you completed the factory reset and Wi-Fi Calling was removed from your phone, have you added it back on?

You can do this using your My Vodafone account or My Vodafone app. Give this a try - you'll then be able to see if you still get the notifications. If you have any problem getting it re-added, pop back to me and let me know; I'll be happy to help you further. 

View more options
4: Newbie

Wi-Fi calling is provisioned in my account.

Screenshot_20190410_160222_com.myvodafoneapp.jpg

But the control to switch it on in the "Phone" section of the "dialler" settings has disappeared. There is no longer the means to switch it on, regardless of whether or not my account is provisioned.

Screenshot_20190410_160357_com.android.phone.jpg

View more options
4: Newbie

Just to see if it would have any effect, I decided to switch it off in My Vodafone and back on again.

My Vodafone is now claiming that I am not eligible for the feature!?!?

[Error ref 1d1]

 

View more options
Moderator

That's strange @grsbanks, if you've had it previously, there should be no problem re-adding it. I can look into getting this back for you 🔎 As I'll need access to your account to do this, please follow the instructions in this private message and I'll be intouch.

View more options
4: Newbie

@Mark it's back now.

The wierd thing is, it takes 12 hours to toggle one way or the other. Toggling it back on results in the "you can't have this" error message, but if you wait long enough it's back on anyway.

So, as things stand now, Wi-Fi calling is once again provisioned on my account (confirmed by the My Vodafone app and the web-based interface) but is still unusable because the settings in the phone allowing me to use it have disappeared since the factory reset that I was advised to do.

The timeline of events so far is:

14/12/2018: It is brought to your attention via this forum (see here) that there is a problem with constant notifications issued by Wi-Fi calling using the default notification tone regardless of the notification settings. The only way to stop this is to set the default notification tone to "silent" with the risk of losing notifications from apps that don't allow the user to override the notification tone used (stock Huawei e-mail app, for example).

24/02/2019: Screenshots of the process used to demonstrate the problem are provided (see here).

26/02/2019: @Natasha states the obvious. Of course coverage is patchy, that's why we need Wi-Fi calling in the first place!
26/03/2019: @Loz says: "Switch the notification to silent or deactivate Wi-Fi calling altogether" -- That's the whole point of this thread. You can't switch to silent and I don't want to deactivate the feature because I need it!

27/03/2019: @Adam says: "Sorry but this is new to us as well". Err... It was brought to your attention 3½ months earlier, during which time everyone has received recommendations to do exactly what we're saying can't be done because of a Vodafone-specific bug (otherwise identical handsets with branded firmware from other operators and unbranded devices don't have this problem), hence raising this topic in the first place.

28/03/2019: @Mark says: "Do a factory reset, this has helped others according to various fora". So I did a factory reset and guess what? All Wi-Fi calling features apart from managing notifications (which doesn't work anyway) are wiped from the phone.

08/04/2019: I report back saying that the other fora actually do not state that other users were helped but that Wi-Fi capabilities were wiped from their phones, as they were from mine.

10/04/2019: @TJ gets hold of the wrong end of the stick and asks me to switch Wi-Fi calling back on in my account. It never was switched off in the first place, it was still on throughout this process. What I no longer have is the feature on the phone to allow me to use this. See here.

10/04/2019: Just to see if it had any effect, I decided to remove Wi-Fi calling from my account and then put it back on (see here). There have been other occasions where the My Vodafone app and the web-based interface both tell me that something is switched on when in fact it is switched off or vice-versa. I've had to speak to a human to get that sorted. Anyway, bad mistake. The UI is broken. You never get the text message confirming this particular change (you get it for other account-related features) but the UI does reflect it, so I'm now wondering if any changes have actually happened?

So what we have is a bug report of which knowledge is denied despite forum members receiving advice to do specifically what they're reporting that they can't do. We then get new advice, acting on which makes things worse. I know that moderators are trying to help and doing what they can within the tight parameters that Vodafone will allow them, but please read and try to understand the information that you are being given and, if there's something you don't get, please ask for more information.

View more options
Moderator

@grsbanks From the information you've given us, we need to discuss it further and look for more information off the public view. Please send us your details by following the message @Mark sent you. 

View more options
4: Newbie

@Adam Already done that and heard back from a certain Jess, who clearly can't think straight because I was asked if I was still getting repeat notifications despite, in the same paragraph, acknowledging that I can no longer activate Wi-Fi calling in the first place.

Not very impressed so far with Vodafone staff's ability to understand the problem at hand, let alone solve it!

View more options
4: Newbie

@Adam @Mark

Is there a number I can call where a human being with the ability to understand a problem will answer? Not someone following a script, but someone who will actually understand what they're being told?

Despite being told that the ability to activate Wi-Fi calling was removed from my phone after the factory reset that I was advised to do by a forum moderator, the escalation team have just told me to...... activate Wi-Fi calling on the phone.

This has gone beyond a joke now.

View more options
13: Advanced Member

My P30 Pro makes a sound and displays a notification that Vodafone wifi call is enabled every time I unlock it.

My BT Mobile SIM just displays the network as BT wifi calling and makes no notification or sound. 

View more options
4: Newbie

Update: Wi-Fi calling is back on the phone now. That's the good news.

The bad news is that it clearly requires Vodafone staff to deactivate and re-provision users' accounts with the service because the switch on "My Vodafone" does not do the job.

While I had the escalation team's ear, I pointed out the original problem that led to Wi-Fi calling being disabled in the first place, i.e. the constant notifications of Wi-Fi calling being available. It would now seem that the same bug has been faithfully copied over to the P30 Pro.

View more options
Moderator

I'm glad to hear Wi-Fi Calling's been re-added to your account @grsbanks. I'm sorry the solution advised by Huawei caused you such an inconvenience.

View more options
2: Seeker

Was this ever fixed, as in a UI or system update? Just switched over to Vodaphone, and I'm a classical musician and can't have notifications souinds going off all the time if I'm in a rehearsal.  Starting to wish I had stayed with EE!

View more options
13: Advanced Member

No. I'm waiting for the next software update. It's out, but not been released over here yet. Maybe that will help. Or not.

View more options
4: Newbie

Nope. It's not been fixed. My best guess is it won't be fixed because doing so is not going to increase Vodafone's revenue. However, I'd be more than happy to be proved wrong!

View more options
4: Newbie

@chistery The update now rolling out is Google's April 2019 security patch. There's nothing from Vodafone in there. If the security patch really is all that's in this update then that means Wi-Fi+ isn't fixed either (that's a purely Android bug, not one of Vodafone's).

View more options
13: Advanced Member

@grsbanks, there are other fixes in the newest update .158 apparently, dual view, better image quality, may security update, for example. 

It's a Vodafone bug, as BT Mobile wifi calling doesn't do it, just Vodafone.

View more options
4: Newbie

@chistery are you using a Huawei P20 Pro?

The update I just got for mine was .270 and it only includes the April 2019 security patch. Nothing else.

View more options