main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

wi-fi calling: continuous notifications it's available - how to stop it?

cdl
4: Newbie

I have an unlocked Huawei P20 Pro, dual sim (CLT-L29). Wi-fi calling works with Vodafone, EE and Three, but Vodafone is the only network which causes constant notifications to pop-up on my phone, to let me know that wi-fi calling is available. I could maybe understand that a notification appears the first time I connect to a wi-fi network (even though no such notification appears with the other 2 mobile operators), but why I sometimes get 3 notifications in 5 minutes, when I am 2 metres from the wi-fi router and with a perfect wi-fi signal, is beyond me.

 

Does this happen to other people? Is it a Vodafone thing? Is it the combination of Vodafone + P20 Pro? Is there a way to stop it?

 

I limited it this way:

 setting -> apps -> more -> show system processes -> phone -> notifications -> wi-fi calling and disable all the options (display in status bar, etc.)

 

but some notifications still filter through.

 

Thanks!

 

 

View more options
33 REPLIES 33
Moderator
Moderator

Hey @cdl, thanks for getting in touch; all those notifications do sound frustrating.

I'm not quiet sure what could be causing them 🤔 Do you have Wi-Fi assist turned on?  I'm wondering if the phone connects to the mobile network which is boosted by your Wi-Fi; then advises you that Wi-Fi Calling is available.

It's worth a check, let us know how you get on 👍

View more options
2: Seeker

I am having the exact same issue since my Huawei updated a few days ago. 

Is incredibly frustrating and I can't seem to stop it..

View more options
16: Advanced member

I had the same with my P20, I never used WiFi calling as I'm never without a signal or if I was and had WiFi I'd use WhatsApp anyway, so I just disabled WiFi calling 

Huawei P20 EML-L09,

Android Version - 9.0.0

Last Update 28.1.19 

Build- 9.0.0.197(C432E7R1P11)

Baseband- 21C20B369S007C000
Nova Launcher. Chrome browser.

My phone history (back to 1997!):

Huawei P20, VF Smart V8, Note 4, S4, S2, Tocco Ultra, F490, P300, E250, RAZR v3, Timeport 250, A300, Star-Tac 

 

View more options
Moderator

Hi @Leenametis have you tried the idea that @TJ suggested at all? 

View more options
2: Seeker

I'm assuming by WiFi assist (ios term) he means wifi+  as in switching between WiFi and 4g?

Yes it's enabled but it's very useful as I have low signal quality at home and my WiFi doesn't reach one room in my house. 

At the moment I've solved the issue above by just turning off WiFi calling but for the reasons above it would be useful to have. 

View more options
1: Seeker

Interesting. I found this thread as I was also having problems with annoying notifications from Vodafone Wi-Fi calling.

Thing is I don't have it enabled, yet I get repeated notifications that it is enabled.

Tried enabling it then disabling it to see if this stopped them, but the problem persists. Anyone got any ideas?

View more options
Administrator

@JaWoody Apart from the advice TJ provided above regarding having Wi-Fi assist active, we can't seem to think what else could be causing these continuous notifications. 

When you're enabling it and disabling it, are you doing this in your phone settings? If so, you may want to also check your My Vodafone app, which will allow you to disable it on your account as well. 

View more options
1: Seeker

@Alex.

I don't have Wi Fi assist enabled as it seems to be a bit finicky at times and find everythings fine with just having Wi Fi and Mobile data enabled as normal. I'll look into the My Vodafone app thanks.

It seems I get the message whenever I go in and out of range of a Wireless network I already have saved on my phone, so it looks like I just automatically get the notification when I connect to a wi fi networks.

In the meantime I've just switched notifications off for this, it doesn't seem to be doing anything untoward, it's just annoying.

View more options
4: Newbie

This is a bug in the Vodafone firmware IMO.

 

I have a P20 Pro that exhibits the same behaviour. I use Wi-Fi calling because the GSM signal where I live is atrocious (not just Voda, no operator is able or can be bothered to provide a decent signal here) and I get an audible notification every time the phone is woken up and Wi-Fi calling is activated. It's extremely annoying.

 

I'm convinced this is a bug having gone through the following steps:

 

1) Turn off all notifications related to Wi-Fi calling by going into "Settings" > "Apps" > "Menu > Show system processes" > "Phone" > "Notifications Management" > "Wi-Fi calling" and switching everything off.

 

Screenshot_20190224_153548_com.huawei.systemmanager.jpg

If you now backtrack one level and go back to "Notifications" you'll see that "Wi-Fi Calling" is still "Enabled":

Screenshot_20190224_153444_com.huawei.systemmanager.jpg

Not only that, but if you change the notification sound, even setting it to "None", it's still the "Default" sound that you get.

 

In short, the settings here have absolutely no effect whatsoever, you always get the default sound whether you want one or not.

View more options
Moderator

Thanks for testing this out and for the screenshots to us @grsbanks.

Are you receiving numerous notifications in minutes as was described from others in the thread? If this is happening, please let me know if switching your phone to airplane mode and having Wi-Fi Calling activated reduces the amount of notifications you're receiving. It may be that the coverage is patchy and the phone is switching between your network coverage and Wi-Fi Calling service. Switching this to airplane mode would prevent the phone from connecting to the network but will still allow Wi-Fi Calling to connect.

View more options
4: Newbie

Hi @Natasha,

 

What happens is, the phone remains on Wi-Fi calling because the GSM signal is really inadequate at home. However, the phone gives me a notification that Wi-Fi calling is active EVERY TIME it wakes up, even if it never switched to mobile while it was asleep. Every time the phone wakes up it's a case of "is Wi-Fi calling active? If so I'll notify the user with a default notification tone even if I'm told to use a different tone or not to do so at all in the settings."

 

I would add this point too... Whether these notifications are coming while the phone is asleep but switching between mobile and Wi-Fi or whether they occur only when the phone is woken up, if the settings say that they shouldn't happen then they shouldn't happen, end of! Either way round, it's a bug.

View more options
4: Newbie

I would add this point too... Whether these notifications are coming while the phone is asleep but switching between mobile and Wi-Fi or whether they occur only when the phone is woken up, if the settings say that they shouldn't happen then they shouldn't happen, end of! Either way round, it's a bug.

View more options
Moderator
Moderator

Thanks for all the feedback @grsbanks, I'll make sure that your comments are passed along to the relevant team to investigate further. If it's something we can fix, we'll be sure to do so; to help improve our customer experience in the future. 

View more options
4: Newbie

Any news on this? It's been a month. And it's definitely something that's been introduced by Voda's alterations to the firmware given that this problem is not there in an unbranded P20 Pro.

View more options
Moderator
Moderator

It's disappointing to hear you're still receiving these notifications regarding your Wi-Fi Calling being active @grsbanks , I understand how frustrating this can be. As you'll be notified each time you're using Wi-Fi Calling and you're unable to turn this off, I'd recommend switching the notification alert to silent.

I understand this may be unsatisfying, unfortunately this isn't something we can change - unless you deactivated Wi-Fi Calling from your services. I'm sorry for any inconvenience that's been caused by this.

View more options
4: Newbie

Hi @Loz,

I'm sorry but you clearly haven't read the rest of this thread. The problem is that we continue to receive these notifications with the default notification tone regardless of the settings, even if notifications for Wi-Fi calling are switched off altogether.

There is no reason this should go away since my previous post here because there have not been any firmware updates other than the usual Google security patches.

For now I have simply switched off Wi-Fi calling because the notifications are just too annoying. This, of course, means that I'm missing calls because the coverage at home is atrocious (hence wanting to use Wi-Fi calling in the first place).

I'm not holding my breath for a fix from Vodafone (this is a Vodafone-specific issue, other firmware variants don't ignore the settings). Fixing this won't increase Vodafone's revenue in any way so the problem report most likely belongs fairly and squarely in the "ignore" bin.

View more options
Moderator

@grsbanks I do understand your position here, I know it's not ideal but this is something new to us as well. I can see through the past comments that settings have been altered, I saw another thread on a third party site that mentioned about 'long pressing' the notification and seeing if it brings up any other actions to stop them coming through. Have you tried this at all? 

View more options
4: Newbie

@Adam

"New" to you? This was raised 3½ months ago...

I have indeed tried what was suggested. All it does is bring you to the same settings page and has the same effect, i.e. none.

View more options
Moderator

I'm sorry this hasn’t resolved the problem with receiving these notifications @grsbanks. I’ve had a look into this for you and Huawei advise backing your phone up and performing a factory reset. This has helped users that have contacted them through their forum.
Let us know how you get on with this.

View more options