main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Broadband connection

Broadband keeps disconnecting several times an hour

View solved solution
14: Advanced member

this will help you to setup the 5gb wifi


but i got a feeling if your on a newer vodafone router you may have the wifi disable and re-enable bug

View more options
4: Newbie

Hi! Just with regarding the wifi aspect, have you split your SSID's?


Here are what Vodafone suggest


They are a bit basic if im honest, however should be enough to get you started.

I have split my SSID's, and labelled them differently on the GUI.

This way, I have 2 wifi networks that appear on my phone. One for 2.4 and one for 5 ghz

This way, i can select which one I want to use per device. eg all my apple devices are now on 5ghz only, leaving the 2.4 free for my laptops/xbox that are generally further away from where the router is plugged in.

I then have a wifi analyser for both networks that will show me what channels are most congested, and I can change the channel based on that. Its a bit tedious however I have seen results on this, I might just need to change the channel once in a while if eg my neighbour changes theirs to the same one and floods the channel with their own devices.

I would suggest not resetting the router and using the 'auto' mode. In my experience, the router never changes the wifi channel based when this channel gets congested. It selects eg channel 1 and even if channel 1 is rubbish, it wont 'auto' change it to a less congested one like BT's does.

However i have heard that the newer router sent to those on gigafast does do this, so never know - it might be coming!

The GUI is generally fairly easy to use once you get used to it. I would however ensure when you first log in, you change from basic to expert mode to ensure you see all of the above suggestions. Some of the support pages do show you how to do this too however.


I hope this helps! And fingers crossed you are closer to finally getting a resolution!

View more options
Moderator (Retired)

Hey @GJA, you've got some great advice already on how to run through the GUI from @gipjon and @HazyDreamer.

There's no need to repeat what they've said already. I'd suggest resettting the rotuer if you can't see the 5Ghz on any device. Once you do this, you'll likely need to run through the steps again to split the SSID etc.

I hope this does help you.

View more options
2: Seeker

I've been having issues with internet dropping since I joined VF about 3 months ago.

I've had endless calls with them asking pointless tests and action that make no sense.

Open Reach have been out twice but the issue remains.

They did once say it was an issue with the router which was swapped and it made no difference.

I hope you have better luck than I am having.

View more options

It's disappointing to hear you've been having these drops outs @xander145 and a new router hasn't helped. 

We'll need to access your account to run some diagnostic and help get you up and running correctly - please contact our team via Facebook at Vodafone UK, or get in touch on Twitter using the handle @VodafoneUK

Alternatively, you can speak to an adviser using Live Chat.

View more options
2: Seeker

I was hoping to see at least one issue like that solved by Vf, but sadly this is an absolute joke...

I've been browsing the forums and there are lots of people with the same issue, internet drops, and same 'solutions' from Vf, reboot, reset, new router... nothing works because to me, it's the software in the router, that is not capable to handle the request or whatever, so it takes its time to process, and of course, that doesn't count as a disconnection for them, as the line is 'active'.

Last time I called Vf, the 'tech' reply to me that 1 minute of Internet is not impacting me (?????). Also, that I needed to use Google DNS for improving the speed of the service...

I will try the 3rd party router

View more options
GJA 3: Seeker
3: Seeker

The final chapter to this sorry tale .... I have insisted on early release from the contract and am moving. 

I will summarise what has been tried to fix this since the problem started a few months ago
(note: we NEVER had this problem with our previous ISP)
The problem
Several times a day, at random times the INTERNET cuts off (internet light flashes) but the wi-fi remains stable and connected (solid green light). The router then re-boots itself (Red power light flashes) and re-sets after two or three minutes, but can take up to 15 or 20 minutes as it sometimes re-sets several times in quick succession.
The internet loss happens randomly and is not associated with time of day, the use of any particular device or the number of users/devices. 
The internet failures also happen when nobody is home and has been logged happening during monitoring and in the router event log as "WAN disconnections". 
Attempted solutions over nearly three months of futile, mind-bending, time-wasting effort. 
  • Over the past two or three months I have spent countless sessions for many, many hours in contact with support teams both on the phone and on-line, carrying out tests, diagnostic trials and equipment adjustments.
  • An engineer from Openreach attended, replaced the main wall socket, tested lines and internal wiring 
  • All leads and filters were renewed 
  • I have replaced all the landline telephones with new ones at great expense and re-sited them in the house
  • I have disconnected and stopped using several wi-fi enabled devices in the house to eliminate them as a cause, this is obviously not satisfactory
  • A new router was finally supplied by VF after a LOT of insistance on my part. I have set it up as instructed with split ssid etc - This made a small temporary difference, but the problem is still there.
  • I have followed advice on this forum to delete all unessaessary settings and functions on the router, one by one to see if any made a difference. No joy
  • The router has been moved to a better location and is directly fitted to it's own mains wall socket
  • I have even tried running the internet and phone line direct in to the main wall outlet 'test socket' through another new filter instead of the front plate for a while.
  • I've allowed repeated periods of 10 -14 days for the line to calibrate (or whatever the terminology is)
  • I purchased a new router having obtained the various log-in codes from the VF support team, unfortunately Vodafone is not commonly supported by plug-and-play routers and lots of other settings needed to be set which were beyond my technical ability, so I returned the router to the supplier.

VF support have maintained contact throughout, but having read so many similar reports on-line, none of which ever seem to be resolved I've given up an am moving. It's probably a bug or glitch with the router or maybe at VF's end of the systems but I'm sure they will never 'fess up and it will quietly be resolved one day. In the meantime customers are being subjected to this nonsense and paying for the privilage. 

Thanks to all who contributed to this thread, I hope others get a better result, bye.

View more options
GJA 3: Seeker
3: Seeker

Having tried everything suggested and left VF, the internet disconnections have stopped and speed has improved slightly as well. I was with TalkTalk before and didn't have the problem, I'm now with Sky and don't have the problem so the internet/router disconnections were clearly a VF issue, probably with the router.

View more options
2: Seeker

Thank you GIA for your detailed account of the problem you had last year. I am just at the start of the same journey and your experience fills me with dread. I do not have the time or patience you clearly havd given to the problem and has persuaded me that perhaps even after 18 months of uninterrupted service, I should consider another provider. I guess it is serendipitous that my contract has just ended and there"s no exit charge now.! Thanks for posting!

View more options