Showing results for 
Search instead for 
Did you mean: 






Error 403 on Vodafone website: cannot register

2: Seeker
2: Seeker

There appears to be no access to the website.

I am trying to register my vodafone mobile account using the website.


I would like to preclude the 'usual' answers I have seen for this first:

* Yes: I have tried multiple browsers
* No, there are no VPN's active and no special restrictions on my internet

* Yes, I have cleared cookies, caches, browsing history and so-on

-None of this makes any difference: It is as if the website itself is basically down. 

Looking on the web, I see I am not the only person who has had this problem

Can anyone provide a meaningful answer to this question?


16: Advanced member
16: Advanced member

Unfortunately this is the broadband forum. You'll have better luck posting in the mobile forums. 

16: Advanced member
16: Advanced member

@niko06  HTTP error 403 is a problem on their side with authorisation.  However suggests that something is not going well right now.

3: Seeker
3: Seeker

From my recent experience as a new customer, the site being down seems to happen quite regularly.

Shortly after midnight on Wednesday 29th Nov the site went down. I tried accessing until 1am but no change. The following night the same happened, except this time a message said there was a problem and come back in the morning - classic.

Those are just since I became a customer, I've had several other occurrencies for a month before I became a customer, I should have learned my lesson.

So the meaningful answer is that it almost certainly isn't your problem, or your routing or anything else like that. The site is flaky, at least the admin (my vodafone) part of it. Sales and storefront seems more robust, go figure.