Showing results for 
Search instead for 
Did you mean: 






My vodafone wifi has stopped letting my phone open apps

3: Seeker
3: Seeker

I recently renewed my WiFi package with Vodafone for the exact same deal, didn't have to do anything but reset the router on the day. However since doing this my Samsung phone has started having problems loading up some apps and stuff in apps. For example the Premier league app has stopped working. Twitter and reddit videos don't load but those apps and pictures load just fine. Random stuff like trying to send gifs on WhatsApp doesn't work.

When I turn off the WiFi these apps open up as normal on my mobile network that is also through Vodafone so I'm confused. I can also connect totally fine to them through my work WiFi so ot is just my home broadband and it has only started since the new package. My wife's phone and all other devices in the house don't seem to be effected. 

Any advise on this would be appreciated


Hi Janey, after more troubleshooting today, I have managed to fix this issue. It had something to do with the IPv6 being checked on my router settings. After unchecking this, all my apps work completely fine and as they should. 

Thank you all the same!

View solution in original position


16: Advanced member
16: Advanced member

You could try setting them to Google DNS ( &, see if that helps. You may find they speed up your browsing too. 

Thanks, Ill give that a go when I am home tonight.

4: Newbie

I've been having the same problem with some apps.
Mychart app (NHS) doesn't work anymore, and others are much slower. I tried everything but it didn't help.

I want to add that they also "renewed" my contract after migration to the Digital Voice service. Since then my problem with several apps started.

Community Manager
Community Manager

Hi @salvom89 - please reach out to our Home Broadband team on 191 free from a Vodafone mobile or 03333 040 191 from another phone. 


3: Seeker
3: Seeker

Have exactly the same issue.

Switched to FTTP on Monday. Using the same router (THG3000) although it reset so I had to restore some of my settings (fixed IP for printer, split wifi and manual channel on 2.4GHz)

Since then, several of my apps (Virgin Money, Tesco Bank, Strava, Clearscore, tado as a start) either don't work at all, slowly or intermittently. Spent quite a bit of time yesterday on chat with Vodafone "support" who advised that I need to contact the app providers! I'm pretty sure I know how those conversations would go ...

Apps work fine on 4G and also fine if I connect to another phone's hotspot.

Hopefully a solution can be found

I contacted Vodafone support yesterday and they escalated my issue to the second line. We'll see how it goes but I am not confident at all.

After days of trying to figure this out, I've finally been able to find a complete fix. 

You will need to log into your router, change the mode to "expert mode" at the top right of the page. Then go to the "Settings" tab along the top and click on "local network" down the left hand side. Scroll down and you'll see "IPv6" is checked. UNCHECK this, scroll all the way to the bottom of the page and click apply. It might take a minute to take effect, but this completely fixed my issues with using my apps. Apps now open as quick as they should, display everything they should and I'm receiving emails as they are sent and not hours later. 

Hope this helps!

This appears to have worked for me - thanks for sharing!!!

Many thanks. I'll try that when I get home later