Showing results for 
Search instead for 
Did you mean: 






Not allowed to set up a smart home

2: Seeker
2: Seeker

Superfast1 Pro customer.

After trying (unsuccessfully) for 3 days to link a new smart plug, I bit the bullet & contacted tech help.

After 2 days of try this/switch this off, I chatted to a pro team member who told me there is no possible way on this Earth to manually change from 5ghz to 2.4ghz.

On explaining my situation - wanting to future-proof our house due to health problems , was told to "wander around the house until the signal drops to 2.4ghz, then connect the device".

I can see 2 problems with this.


I am not paying Voda so I can "wander" (sooo 21st century).


The device is a fixed twin socket outlet. Anyone got a pick-axe I can borrow??

Got through to the complaints dept. to be told "everyone is in the same boat". Oh! That's ok, then. I'll just roll over & go away.

Have tried all the "solutions" on here....quelle surprise Rodders...they don't work.

COME ON VODAFONE.....give your paying customers back the option to switch to 2.4ghz.

I for one am voting with my feet after Chrimbo.


16: Advanced member
16: Advanced member

Better make sure your complaint is officially registered and that you go through the procedure and take it to the Alternative Dispute Resolution (ADR) and  CICAS if necessary, or they will probably try to impose a penalty if you leave early.


Have already informed them that, as the product is not fit for purpose &  I was lied to at point of worries, this product will seamlessly integrate with any smart home device... with that, they can take a running jump.

They had to concede. They then tried offering compensation. Note to readers...once you accept any form of compensation, they have "rectified" the problem & are not required to further the complaint. DO NOT accept any form of compensation until you are 100% satisfied.

Anyone know of a broadband provider that still offers the ancient art of being able to choose your own bandwidth???

16: Advanced member
16: Advanced member


Could you show just what settings are available on the Wi-Fi General tab in the router, when you have Pro?

Us non-Pro users have this:



Hi Jayach.

Under general wifi settings, setup:

Main wifi

Wifi name (ssid)

Protection mode

Wifi password

Wifi above

Apply/cancel, reset to default settings.

Above all of this there is a red box (Danger, Will Robinson) stating:

Super wifi is running your wifi settings. Please use the super wifi tile in the Vodafone Broadband App to manage your settings.

Guess how I got to this point?

Correct...using the super wifi tile in the Vodafone Broadband App....GRRRRR!!!

In wifi settings it states:

you can change parameters for the two wifi frequencies 2.4ghz & 5ghz followed by same "Danger, Will Robinson" box.


wifi mode (then drop down box with options):

Mixed 802.11b/g/n (option checked)

Mixed 802.11b/g


20mhz (checked)




Wifi mode

Mixed 802.11n/ac (no other options)


20/40/80mhz (checked)



Apply/cancel, reset to default settings




16: Advanced member
16: Advanced member

As I suspected they have removed the option to turn off the 5Ghz temporarily whilst setting up the smart home devices.  Not good :Sad_face:

Not applicable

This is a workaround that does work!


If you set up a mobile phone as a 2.4GHz hotspot using the same SSID and Password as you have set on the router, you can turn the router off and then set up your SmartHome devices.  Once set up, turn off the hotspot and turn the router back on!

Hi Keith.

Thanks for the reply.

Am using a Galaxy A71. On configure mobile hotspot, there is no option to program the SSID.

Network name.

Security - WPA2-personal (checked) WPA2/WPA3-personal, WPA3-personal.


Band. CHOICE of 5ghz or 2.4ghz TAKE NOTE VODAFONE...IT GIVES A CHOICE...Set at 2.4ghz

On advanced settings there is:

Broadcast channel drop down - Auto (checked) or 1 thru 11.

MAC address type - Randomise MAC (checked) or Phone MAC.

Am I missing something?


16: Advanced member
16: Advanced member

I would think "Network name" is the SSID

This workaround definitely works, bit of a faff, but a life-saver.  Many thanks to the poster!