Showing results for 
Search instead for 
Did you mean: 






ftp server with Vodofone Pro router - problems

3: Seeker
3: Seeker

Hi - trying to restore my ftp server on a new Broadband Pro installation.  Actually all pretty good apart from setting port forwarding.  Fixed IP for the NAS, opened port 21, but incoming requests are being timed out.  Firewall off, no difference.  (Technical support was useless - advised using my own router ?!?!).  The router web app is so slow and  unhelpful compared to my old tplink router.


Anyone had experience with the Pro Broadband router and ftp?




16: Advanced member
16: Advanced member

Is this Pro with FTTP or FTTC?

I can't imagine there will be much experience with FTP, I didn't think anyone used it anymore.

FTTC - we changed from Plusnet and overall the Vodafone service seems better, almost 50% faster.  The ftp server runs a web application and, sure, its old tech, but its used a lot in my field. Vodafone tech support just didnt know what I was talking about.... 

3: Seeker
3: Seeker

Solved - After opening ports 20 and 21 to the fixed IP NAS external ftp requests were blocked, even after turning the firewall off. Activating the 'Exposed Host Function' to bypass the firewall solved the problem and the server now responds normally to ftp requests.

Community Manager
Community Manager

Thanks for keeping the thread updated and letting us know @DAVEMATTEY  🙂

Did this cause you any issues with your NAS being exposed?. I've found that FTP and port forwarding (ports 20 & 21) only fails when used in pasive mode, active mode still works and maybe less risky

It did.  I was hacked and encrypted for  ransomeware.  Never think it happens to someone else!  The hack targetted my type of NAS (QNAP) with outdated firmware and I had missed warning to install a security patch becasue of this hack.  My hacker was terribly polite and advised me to keep softare up to date, but still wanted his bitcoin.  B£$@£$!  I'll be ditching this vodafone kit when the contact expires in a few months.  The new phone app just doesnt work properly.  Dreadfull.

I agree, it's pretty ##~##., unfortunately for me I've just moved from Sky so stuck with it for 2 years then it will be bye bye (and thats after less than a week). The support from Vf is shocking and the router is sooooo slooooow to respond it's grossly underpowered. Ive already had 5 calls with Vf in less than a week about the transfer of my service to them - on the first contact they reset my router back to factory conf with even discussing it and so I lost everything I'd done on the config, and it also dropped the call that I was on with the supoport team !!!

16: Advanced member
16: Advanced member

@DAVEMATTEY Sorry, but I've got ask; why didn't you make the external port a high number like 12345 instead of leaving it on 21? Also did you consider installing the FileZilla Server to manage the external connection and therefore protect the NAS?

Thanks for the enquiry,  I didn't - its not a simple set up which continuously ftp's data locally to the NAS, then to  cloud storage and a web app...  so I stuck to a basic configuration!  Yep, I know I should have...  😕  I used to have TP l link and Archer routers but was seduced by the Vodafone deal and promise of wifi in every room, so swopped over.   Big mistake.... 

Can anyone recommend a broadband/mobile/landline deal that supplies kit thats fast, reliable and configurable without the stupid phone app?