main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Mobile Broadband

Gigacube and slow to load pages

3: Seeker

We have just moved from EE 4GEE to Vodafone Gigacube due to the unlimited data package.  Only 1 day in and there is definitely an issue with the Gigacube devices or firmware.

 

Whilst the speed is 50+mbps loading of pages can take upto a minute.  

 

I have dropped the sim into another unlocked 4G device and this worked without an issue, so the fault with the Huawei device which is really disappointing.

 

I have seen a few other issues but seriously need to resolved this within the next 13 days because if its not fit for purpose then I will raise further.

 

Can I please get some guidance. 

View more options
13 REPLIES 13
Moderator

Hi @rgiblin, is it taking this long to load pages on every device? We know you've only been up and running a few days, however, it might be worth checking the Network Status Checker here to see if anything is happening in the area. 

Can you also let us know the other issues that you're facing please? 

View more options
3: Seeker

Hi @markd thanks for responding.

 

No network issues in area - and 4G speed/signal is awesome.

 

Yup.....take this long on all devices.  😞

View more options
3: Seeker

Worth noting I have popped the sim into a Mobile device, and experienced no issues at all which leads me to think it maybe the Gigacube device itself has an issue?

 

It has the latest firmware to my knowledge

 

 

View more options
Moderator

If there's no issues with your local network and you're able to connect with no issue with your Gigacube SIM in another device, we'll need to take a closer look into this for you @rgiblin. As we may need access to your account. Pop us a message through one of our social channels and we'll be happy to check this for you 😊

View more options
3: Seeker

Thanks - I have already escalated.

 

They are sending out a new Gigacube tomorrow which I hope will resolve.  Tech have looked and done some tests and this was deemed the best course of action.

Fingers crossed 🙂

View more options
Moderator

Hi @rgiblin That`s great to hear, let us know how you get on 😊 

View more options
2: Seeker

@rgiblin - did you get this issue sorted? I received a new 5G Gigacube on Thursday and having the same issue with slow loading of pages. All other services like video calls, Netflix etc are working great. Which leads me to believe its DNS... but can't be sure.

 

Again, my actual network connection speed is great, it's the page loading that takes ages. I tried setting manual DNS on the router but still no joy, so maybe its not DNS.

View more options
2: Seeker

Potential Solution

I think I may have found a solution to all the ‘slow Gigacube loading page/DNS related issues’.

After doing some reading on these forums I started to look at APN settings in my 5G Gigacube (Huawei 5G CPE Pro). In particular, the ‘IP type’ setting. So… I went into Network Settings—>Mobile Network—>Internet Connection—>APN List and saw a list of APNs, with the default being ‘Other Pay monthly’. Given that you can’t edit these APNs, I decided to create a new one, with the following settings which now include the Cloudflare DNS:

Profile name: Internet (this can be anything I think)
Set as Default Profile: Checked (this gets selected by default but make sure it’s checked)
User name: web
Password: web
Authentication: PAP
IP type: IPv4 & IPv6
APN: wap.vodafone.co.uk
Set DNS server manually: Checked
Primary IPv4 DNS server: 1.1.1.1
Secondary IPv4 DNS server: 1.0.0.1
Primary IPv6 DNS server: 2606:4700:4700::1111
Secondary IPv6 DNS server: 2606:4700:4700::1001

Click ‘Save’ and I don’t even think you need to restart router. Thats it!!

I’ve been running with this now for an hour. I am going to keep an eye on it over the next hours/days, and will report back status, but so far so good. All of the above issues are now gone. 🤞

So it perhaps seems that the APN's DNS settings override anything that is set in Network Settings—>Ethernet—>Dynamic IP.

TL;DR

I received 5G Gigacube (Huawei 5G CPE Pro) on Thursday. I’m in a 4G only area but it still works (a story for a different day).

The network signal is great and 4G speeds are so much better than my landline ADSL connection. I’m in a rural area and hence why I wanted mobile broadband.

Signal:

RSRQ -7.0dB
RSRP -82dBm
RSSI -63dBm
SINR 16dB

Speedtest.net Results:

Server: Mauritius Telecom Ltd - London (id = 17418)
        ISP: Vodafone
    Latency:    33.02 ms   (6.78 ms jitter)
   Download:    54.80 Mbps (data used: 62.1 MB)                               
     Upload:    29.14 Mbps (data used: 39.3 MB)                               
Packet Loss:     0.0%
 Result URL: https://www.speedtest.net/result/c/fd18a191-2bf7-4a29-94d9-e400cfefac46

 

PingPlotter also showed a very stable connection over a long term.

My issues were:

  • Web pages taking an age to load (Chrome dev tools showed delays with ‘Wait (TTFB)’ and also DNS resolution
  • Apps such as BBC Sport on wifi connected devices taking up to a minute to load, and sometimes even timing out
  • Running Speedtest app on iPhone was taking a long time grabbing an available server

No issues with:

  • Streaming services running on Apple TV
  • Video calls (Google, FaceTime etc.)

My home network consists of Gigacube 5G (with wifi turned off) and the WAN port used to connect 4 different wifi access points throughout the house using Powerline adapters. Note: this infrastructure worked perfectly with my old ADSL connection, so I know this wasn’t the issue. Furthermore, I connected directly to the Gigacube to cut out the chance that it could be Powerline/wifi issues.

I tried manually setting the DNS to Cloudflare in the Gigagcube under Network Settings—>Ethernet—>Dynamic IP but this didn’t seem to work.

I also tried turning my Gigacube into a ‘modem only’ (Bridge Mode) and let my home network router do DHCP, NAT etc. However, I was getting ‘Double NAT’ issues, as apparently Vodafone won’t let you do this. (Terrible, but again I digress.)

View more options
3: Seeker

Well I hope it sorta it out for you - sounds like good progress. 

I ran out of time to test any further so have arranged to cancel my contract and the Gigacube is being returned today. 

I am sure I’ll try it again at some point but right now what with home working etc I need a stable connection that I can rely on. 

View more options
2: Seeker

So it looks like the reply I made with the solution has been removed by these forums - they said it was spam?!!

 

The solution is still working for me btw!!!

 

In summary, the solution was to create a new APN on the router, and use your own DNS. 

 

Just another way for Vodafone to make it hard for customers.

View more options
2: Seeker

Good work my man, I am trying it out.... i am still with in my 14 days right of return so will let you guys know if works

View more options
3: Seeker

I've just tried this fix and it's looking really promising, thank you for sharing! Will post back after I've used it for a while longer.

View more options
2: Seeker

Good stuff. I've been using this fix now for over a month with no issue at all. If only Vodafone would ship the Gigacubes with this...

View more options