main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Mobile Broadband

Super slow gigacube 4g.

Highlighted
3: Seeker

The phones won't be better than the gigacube, their aerials are much smaller. The gigacube will be superior, so I doubt what you been told by tech support is true.

 

I had a time of no signal on our phones, yet the gigacube maintained full strength, which proves my suggestion above.

 

Usually when something not right, I report it, it gets fixed shortly after but no-one ever tells me why. Doesn't help when it goes wrong next time, i can't simply say what the problem was last time and tell them, i have to jump through hoops of tests, reboots etc wasting loads of time.

View more options
Highlighted
4: Newbie

I've now bit the bullet and ordered a landline broadband. Sure it won't be installed until July and it will only be 14Mbps but at least it will be stable. I'll be telling Vodafone not to renew my contract when it expires.

 

I can't waste any more time talking to tech support for no gain. 

View more options
Highlighted
Moderator

Where in your home is the Gigacube positioned @abates85?

View more options
Highlighted
4: Newbie

Hi DaneB. The gigacube is located in our front window on the 2nd floor . A person on tech support said our mast was located in our town centre so I put the gigacube in a location of least resistance on the 2nd floor of our home. To accommodate this I have installed a whole home WiFi system for full coverage. The speeds are the same wether wired directly to the gigacube or through the gigacube WiFi or the whole home WiFi. so the whole home WiFi is not the issue. 

 

I have had the router in different locations with varying speeds it appears the current locations has been the most successful as the speed occasionally get a 4g+ connection. 

View more options
Highlighted
4: Newbie

@DaneB I've managed to resolve my issue. I've bought my own 4g router. 

 

It is in the same place where the gigacube was. I'm now getting average 50Mbps down and 15Mbps up as opposed to 0.2Mbps down and 12Mbps up. The broadband has been stable at this for 2 days so far. 

 

The router I've bought for others information is the tp-link Archer MR600 ##~##

Since this was an issue with the router I'm going to ring billing to request the reduce my contract to just the unlimited data contract for home mobile broadband which is significantly cheaper than the gigacube contract. £33 Vs £50. 

[MOD EDIT: This post has been edited to remove off topic content, please see Community Guidelines]

View more options
Highlighted
2: Seeker

I am in exactly the same position. Speeds were great when i got it and since then they have steadily declined. I am connected direct by gigabit ethernet cable to the router ns have just run. speedtest and getting 1.49mbs download and 0mbs upload. I have removed sim last night and reinserted and no difference. This is very disappointing as I paid £325 upfront for this and paying £50 a month and today its taking ages to even load normal web pages

View more options