main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Mobile Broadband

Unusable mobile broadband

DrKaz
2: Seeker

I've had to resort to posting here after receiving no resolution via Customer Services.

 

My 4g mobile broadband speed has deteriorated from over 25Mbps download last year to less than 10Mbps in January/February, and now it is less than 1Mbps (it was actually 0.18Mbps when I tested it about 30 minutes ago). As I normally work from home (not just during COVID), and rely on video conferencing to perform my job, the speeds I now receive mean I am pretty much cut-off and I am unable to work effectively.

 

I have repeatedly followed all the recommendations suggested by Customer Services - removing the SIM, resetting, changing server etc., and this has had no effect whatsoever on the numerous occasions I have spoken with them.  My last call in February finished with the Customer Service Advisor telling me an engineer would contact me, which of course they have not.

 

As I am unable to perform my normal work activities, and I am no longer receiving the same service I originally received, I expect to be released from my contract at no further cost to me. If this is not acceptable I will be seeking third party advice.

 

Thank you for listening.

View more options
5 REPLIES 5
Farai
Moderator

Hey @DrKaz I'm really sorry to hear about the coverage issue you've experiencing recently. We'd certainly like to help you get to the bottom of what's going on. So we can better understand, help us rule out some of the common factors relating to low coverage by providing me with the answers to the following questions:

1) Does the issue happen in just one location? If so, how far do you have to travel to regain service?

2) What is the full postcode (e.g. ST1 1AA) of where the issue occurs?

3) Does the issue occur if you try your SIM card in a different phone?

4) What errors have you seen or heard when the issue occurs?

5) Does this happen on 2G, 3G, 4G or all?

6) When did you first notice this issue?

7) Is the issue permanent or intermittent? If intermittent, are there specific times of the day when it happens?

View more options
DrKaz
2: Seeker

Dear Farai, thank you for your reply, but have you actually read my message?  This is not an issue with broadband on my mobile phone.

 

1. This is mobile broadband via a Gigacube, not broadband on my mobile phone, therefore it is in a single location at a premises.

2. CA6 6HA

3. The SIM is in the Gigacube.  This is not a problem with mobile broadband on my phone, this is a mobile broadband device used in my home as I do not have access to suitable fixed broadband.

4. ?? The error is poor broadband speed, there are no errors or sounds, just crap speed.

5. 2G and £g are useless at the postcode mentioned, 4G has deteriorated from over 25Mbps to virtually nothing.

6. At least 7-8 months ago the speed had dropped from >25Mbps to around 10Mbps. 

7. Speeds of around 3-5Mbps are pretty permanent, <1Mbps is random throughout the day.

 

View more options
Jack
Moderator

Thanks for sending this over @DrKaz. I've checked over the network strength in your area using our network checker here, and I can see that your postcode in on the edge of an area with patchy to low network strength across 2G, 3G, and 4G signals so a generally low signal strength is to be expected, but not at the deterioration you've described. Does restarting or resetting your Gigacube help improve things at all?

View more options
DrKaz
2: Seeker

Hi Jack,

Thank you for your reply. 

According to the Vodafone status checker at my postcode I should receive poor 2G, slightly better 3G and OK (for mobile broadband in this area) 4G coverage both inside and outside. It is not on the edge of an area with patchy coverage (see below).

DrKaz_0-1619282597612.png

Also according to the network checker for that postcode I should receive 3.2-49Mbps 4G. I get nothing of the sort.

DrKaz_1-1619282812687.png

Resetting the Gigacube (or turning it off and on) has no effect.  I have both a 5G Gigacube (which I was assured would work perfectly fine with 4G) and a 4G Gigacube.  Neither gives me anything like the speed I originally received when I first took out the Vodafone mobile broadband contract using the 4G Gigacube.  I have not changed the location of the Gigacube and I am not using additional devices - in fact I am using fewer devices now.

If this cannot be sorted I will be terminating my contract and do not expect to have to pay an early termination fee.

Many thanks,

DrKat

 

 

View more options
Jack
Moderator

If you zoom out on the page @DrKaz, you can see the wider network strength in your area including the patchier coverage locations. Given the deterioration of your service, I'd recommend contacting our Social Media here, so that the team can run some more in-depth troubleshooting for you. We may need to send you device off for repairs if necessary.

View more options